aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gpe-su
diff options
context:
space:
mode:
authorAndrea Adami <andrea.adami@gmail.com>2009-05-01 16:22:05 +0200
committerAndrea Adami <andrea.adami@gmail.com>2009-05-01 16:22:05 +0200
commit17c1e6796e06e87d00f69ade3d36e23caa95ab45 (patch)
tree56eada1e21f93427a5215746dee866e35f5bd959 /recipes/gpe-su
parent90a600967823fd98fcc2c3aa0efccb15ff2196a0 (diff)
downloadopenembedded-17c1e6796e06e87d00f69ade3d36e23caa95ab45.tar.gz
gpe-su: Makefile fix - don't strip on install
Diffstat (limited to 'recipes/gpe-su')
-rw-r--r--recipes/gpe-su/files/makefile-fix.patch11
-rw-r--r--recipes/gpe-su/gpe-su.inc2
2 files changed, 13 insertions, 0 deletions
diff --git a/recipes/gpe-su/files/makefile-fix.patch b/recipes/gpe-su/files/makefile-fix.patch
new file mode 100644
index 0000000000..cce98b1656
--- /dev/null
+++ b/recipes/gpe-su/files/makefile-fix.patch
@@ -0,0 +1,11 @@
+--- /tmp/Makefile.old 2008-07-14 22:34:47.000000000 +0200
++++ gpe-su-0.20/Makefile 2009-05-01 16:02:11.000000000 +0200
+@@ -34,7 +34,7 @@
+
+ install-program: all $(PACKAGE).desktop
+ mkdir -p $(DESTDIR)$(PREFIX)/bin
+- install -m 755 -s $(PACKAGE) $(DESTDIR)$(PREFIX)/bin/$(PACKAGE)
++ install -m 755 $(PACKAGE) $(DESTDIR)$(PREFIX)/bin/$(PACKAGE)
+ mkdir -p $(DESTDIR)$(PREFIX)/share/applications
+ install -m 644 $(PACKAGE).desktop $(DESTDIR)$(PREFIX)/share/applications
+ mkdir -p $(DESTDIR)$(PREFIX)/share/pixmaps
diff --git a/recipes/gpe-su/gpe-su.inc b/recipes/gpe-su/gpe-su.inc
index 3daa0b9e0a..287915e6f6 100644
--- a/recipes/gpe-su/gpe-su.inc
+++ b/recipes/gpe-su/gpe-su.inc
@@ -6,3 +6,5 @@ DEPENDS = "libgpewidget virtual/libintl"
SRC_URI = "${GPE_MIRROR}/${PN}-${PV}.tar.gz"
inherit gpe pkgconfig
+
+SRC_URI += "file://makefile-fix.patch;patch=1"