aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gpe-watch
diff options
context:
space:
mode:
authorSteve Sakoman <steve@sakoman.com>2009-05-08 18:25:38 +0200
committerFlorian Boor <florian.boor@kernelconcepts.de>2009-05-08 18:33:27 +0200
commit2d6944c4536c988493ad1611019624ddaab8de2e (patch)
tree0876beb6a902e2208bb74771f59b9b38ef2057dd /recipes/gpe-watch
parenteb2aaa10876bfe45c1863e83adb54db26cde4c84 (diff)
downloadopenembedded-2d6944c4536c988493ad1611019624ddaab8de2e.tar.gz
gpe-watch: Fix install: don't do install -s
Diffstat (limited to 'recipes/gpe-watch')
-rw-r--r--recipes/gpe-watch/gpe-watch-0.10/fix_install.patch13
-rw-r--r--recipes/gpe-watch/gpe-watch_0.10.bb5
2 files changed, 17 insertions, 1 deletions
diff --git a/recipes/gpe-watch/gpe-watch-0.10/fix_install.patch b/recipes/gpe-watch/gpe-watch-0.10/fix_install.patch
new file mode 100644
index 0000000000..3ae63a839f
--- /dev/null
+++ b/recipes/gpe-watch/gpe-watch-0.10/fix_install.patch
@@ -0,0 +1,13 @@
+diff --git gpe-watch-0.10/Makefile-orig gpe-watch-0.10/Makefile
+index 2f74616..58fa802 100644
+--- gpe-watch-0.10/Makefile-orig
++++ gpe-watch-0.10/Makefile
+@@ -39,7 +39,7 @@ $(PACKAGE): $(OBJS) $(LIB)
+
+ install-program: all $(PACKAGE).desktop
+ mkdir -p $(DESTDIR)$(PREFIX)/bin
+- install -s $(PACKAGE) $(DESTDIR)$(PREFIX)/bin/$(PACKAGE)
++ install $(PACKAGE) $(DESTDIR)$(PREFIX)/bin/$(PACKAGE)
+ mkdir -p $(DESTDIR)$(PREFIX)/share/pixmaps
+ install -m 644 $(PACKAGE).png $(DESTDIR)$(PREFIX)/share/pixmaps/$(PACKAGE).png
+ #mkdir -p $(DESTDIR)$(PREFIX)/share/$(PACKAGE)
diff --git a/recipes/gpe-watch/gpe-watch_0.10.bb b/recipes/gpe-watch/gpe-watch_0.10.bb
index e0d514701c..9b386a2755 100644
--- a/recipes/gpe-watch/gpe-watch_0.10.bb
+++ b/recipes/gpe-watch/gpe-watch_0.10.bb
@@ -1,5 +1,6 @@
LICENSE = "GPL"
inherit gpe pkgconfig
+PR = "r1"
DESCRIPTION = "GPE analog clock-watch"
DEPENDS = "gtk+ libgpewidget"
@@ -7,4 +8,6 @@ SECTION = "gpe"
PRIORITY = "optional"
SRC_URI += "file://fix_makefile.patch;patch=1 \
- file://no-render-h.patch;patch=1"
+ file://fix_install.patch;patch=1 \
+ file://no-render-h.patch;patch=1 \
+ "