aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gpe-what/gpe-what-0.33/makefile-fix.patch
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/gpe-what/gpe-what-0.33/makefile-fix.patch
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/gpe-what/gpe-what-0.33/makefile-fix.patch')
-rw-r--r--recipes/gpe-what/gpe-what-0.33/makefile-fix.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes/gpe-what/gpe-what-0.33/makefile-fix.patch b/recipes/gpe-what/gpe-what-0.33/makefile-fix.patch
new file mode 100644
index 0000000000..3e48d63465
--- /dev/null
+++ b/recipes/gpe-what/gpe-what-0.33/makefile-fix.patch
@@ -0,0 +1,21 @@
+--- gpe-what-0.33/Makefile.orig 2005-11-03 21:41:33 +0100
++++ gpe-what-0.33/Makefile 2005-11-03 21:45:10 +0100
+@@ -6,16 +6,14 @@
+
+ MEMBERS = gpe-what mbtray
+
+-PACKAGE_CFLAGS += $(STANDARD_CFLAGS) $(GTKCFLAGS)
+-PACKAGE_LDFLAGS += $(GTKLDFLAGS)
++PACKAGE_CFLAGS += $(STANDARD_CFLAGS) $(GTKCFLAGS) `pkg-config --cflags libmb`
++PACKAGE_LDFLAGS += $(GTKLDFLAGS) `pkg-config --libs libmb`
+ PACKAGE_CPPFLAGS += -DPACKAGE=\"$(PACKAGE)\" -DPREFIX=\"$(PREFIX)\" -DPACKAGE_LOCALE_DIR=\"$(PREFIX)/share/locale\"
+
+ OBJS = $(patsubst %,%.o,$(MEMBERS))
+ DEPS = $(patsubst %,%.d,$(MEMBERS))
+ SOURCES = $(patsubst %,%.c,$(MEMBERS))
+
+-PACKAGE_LDFLAGS += -lmb
+-
+ ifeq ($(CVSBUILD),yes)
+ BUILD = ../build
+ else