aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gpgme
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/gpgme
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/gpgme')
-rw-r--r--recipes/gpgme/gpgme.inc28
-rw-r--r--recipes/gpgme/gpgme_1.0.0.bb3
-rw-r--r--recipes/gpgme/gpgme_1.0.3.bb3
-rw-r--r--recipes/gpgme/gpgme_1.1.4.bb3
4 files changed, 37 insertions, 0 deletions
diff --git a/recipes/gpgme/gpgme.inc b/recipes/gpgme/gpgme.inc
new file mode 100644
index 0000000000..e89d402b6a
--- /dev/null
+++ b/recipes/gpgme/gpgme.inc
@@ -0,0 +1,28 @@
+DESCRIPTION = "GnuPG Made Easy (GPGME) is a library designed to make access to GnuPG easier for applications"
+HOMEPAGE = "http://www.gnupg.org/gpgme.html"
+LICENSE = "GPL"
+DEPENDS = "libgpg-error pth libassuan"
+RRECOMMENDS_${PN} = "gnupg"
+
+SRC_URI = "ftp://ftp.gnupg.org/gcrypt/gpgme/gpgme-${PV}.tar.gz"
+
+EXTRA_OECONF = "--with-pth=${STAGING_DIR_HOST}${layout_exec_prefix} --without-pth-test --with-gpg=${bindir}/gpg --without-gpgsm"
+
+LEAD_SONAME = "libgpgme.so"
+
+inherit autotools binconfig
+
+do_stage() {
+ autotools_stage_includes
+
+ install -d ${STAGING_LIBDIR}
+ oe_libinstall -C gpgme -so libgpgme ${STAGING_LIBDIR}
+ oe_libinstall -C gpgme -so libgpgme-pth ${STAGING_LIBDIR}
+ oe_libinstall -C gpgme -so libgpgme-pthread ${STAGING_LIBDIR}
+
+ install -d ${STAGING_DATADIR}/aclocal
+ install -m 0644 gpgme/gpgme.m4 ${STAGING_DATADIR}/aclocal/
+}
+
+FILES_${PN} = "${libdir}/libgpgme*.so.*"
+FILES_${PN}-dev += "${bindir}/gpgme-config"
diff --git a/recipes/gpgme/gpgme_1.0.0.bb b/recipes/gpgme/gpgme_1.0.0.bb
new file mode 100644
index 0000000000..2b8b07c90e
--- /dev/null
+++ b/recipes/gpgme/gpgme_1.0.0.bb
@@ -0,0 +1,3 @@
+require gpgme.inc
+
+PR = "r3"
diff --git a/recipes/gpgme/gpgme_1.0.3.bb b/recipes/gpgme/gpgme_1.0.3.bb
new file mode 100644
index 0000000000..2b8b07c90e
--- /dev/null
+++ b/recipes/gpgme/gpgme_1.0.3.bb
@@ -0,0 +1,3 @@
+require gpgme.inc
+
+PR = "r3"
diff --git a/recipes/gpgme/gpgme_1.1.4.bb b/recipes/gpgme/gpgme_1.1.4.bb
new file mode 100644
index 0000000000..68d71aab28
--- /dev/null
+++ b/recipes/gpgme/gpgme_1.1.4.bb
@@ -0,0 +1,3 @@
+require gpgme.inc
+
+PR = "r5"