aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gphoto2/libgphoto2_2.1.4.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/gphoto2/libgphoto2_2.1.4.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/gphoto2/libgphoto2_2.1.4.bb')
-rw-r--r--recipes/gphoto2/libgphoto2_2.1.4.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes/gphoto2/libgphoto2_2.1.4.bb b/recipes/gphoto2/libgphoto2_2.1.4.bb
new file mode 100644
index 0000000000..fed7c41e40
--- /dev/null
+++ b/recipes/gphoto2/libgphoto2_2.1.4.bb
@@ -0,0 +1,29 @@
+SECTION = "libs"
+DEPENDS = "jpeg libusb libexif"
+DESCRIPTION = "libgphoto2 allows you to access digital cameras"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/gphoto/libgphoto2-${PV}.tar.bz2"
+
+EXTRA_OECONF_mnci = "--with-drivers=canon --without-serial"
+LICENSE = "GPL"
+inherit autotools pkgconfig
+
+do_stage() {
+ install -d ${STAGING_LIBDIR}
+ mv libgphoto2/.libs/libgphoto2.so.2.0.3T libgphoto2/.libs/libgphoto2.so.2.0.3 || true
+ oe_libinstall -so -C libgphoto2 libgphoto2 ${STAGING_LIBDIR}
+ oe_libinstall -so -C libgphoto2_port/libgphoto2_port libgphoto2_port ${STAGING_LIBDIR}
+
+ install -d ${STAGING_LIBDIR}/gphoto2/2.0
+ oe_libinstall -so -C camlibs/canon libgphoto2_canon.so ${STAGING_LIBDIR}/gphoto2/2.0
+
+ install -d ${STAGING_INCDIR}/gphoto2
+ for X in gphoto2-abilities-list.h gphoto2-camera.h gphoto2-context.h gphoto2-file.h gphoto2-filesys.h gphoto2.h gphoto2-library.h gphoto2-list.h gphoto2-result.h gphoto2-setting.h gphoto2-version.h gphoto2-widget.h
+ do
+ install -m 0644 ${S}/libgphoto2/$X ${STAGING_INCDIR}/gphoto2/$X
+ done
+ for X in gphoto2-port.h gphoto2-port-info-list.h gphoto2-port-log.h gphoto2-port-version.h gphoto2-port-portability.h gphoto2-port-result.h
+ do
+ install -m 0644 ${S}/libgphoto2_port/libgphoto2_port/$X ${STAGING_INCDIR}/gphoto2/$X
+ done
+}