summaryrefslogtreecommitdiffstats
path: root/recipes/gphoto2/libgphoto2_2.4.7.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-01-06 11:48:33 +0100
committerKoen Kooi <koen@openembedded.org>2010-01-06 11:50:31 +0100
commit05209582802728449bcf9440f36cb773744aea75 (patch)
tree314076d0519f12db84df32e3e92b3604f4724df4 /recipes/gphoto2/libgphoto2_2.4.7.bb
parentf20ec3b93191128a053236782d56c85afe565e2c (diff)
downloadopenembedded-05209582802728449bcf9440f36cb773744aea75.tar.gz
libgphoto2: add hal .fdi files
* these where generated from the source tree to avoid heavy patching or needing to use qemu to generate the list
Diffstat (limited to 'recipes/gphoto2/libgphoto2_2.4.7.bb')
-rw-r--r--recipes/gphoto2/libgphoto2_2.4.7.bb25
1 files changed, 23 insertions, 2 deletions
diff --git a/recipes/gphoto2/libgphoto2_2.4.7.bb b/recipes/gphoto2/libgphoto2_2.4.7.bb
index 45d42c398c..1994c76a15 100644
--- a/recipes/gphoto2/libgphoto2_2.4.7.bb
+++ b/recipes/gphoto2/libgphoto2_2.4.7.bb
@@ -3,7 +3,17 @@ SECTION = "libs"
LICENSE = "GPL"
DEPENDS = "libtool jpeg virtual/libusb0 libexif"
-SRC_URI = "${SOURCEFORGE_MIRROR}/gphoto/libgphoto2-${PV}.tar.bz2"
+# The .fdi and .rules files were generated with:
+# libgphoto2-2.4.7/packaging/generic$ qemu-arm -s 1048576 -r 2.6.24 -L /OE/angstrom-dev/staging/armv5te-angstrom-linux-gnueabi/ .libs/print-camera-list
+# They are release specific, so please regen when adding new releases
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/gphoto/libgphoto2-${PV}.tar.bz2 \
+ file://10-camera-libgphoto2-device.fdi \
+ file://10-camera-libgphoto2.fdi \
+ file://90-libgphoto2.rules \
+"
+
+PR = "r1"
inherit autotools pkgconfig lib_package
@@ -12,13 +22,24 @@ OE_LT_RPATH_ALLOW[export]="1"
EXTRA_OECONF = " --with-drivers=all ac_cv_lib_ltdl_lt_dlcaller_register=yes"
+do_install_append() {
+ install -d ${D}${datadir}/hal/fdi/information/20thirdparty
+ install -m 0644 ${WORKDIR}/*.fdi ${D}${datadir}/hal/fdi/information/20thirdparty/
+
+ install -d ${D}${sysconfdir}/udev/rules.d/
+ install -m 0755 ${WORKDIR}/*.rules ${D}${sysconfdir}/udev/rules.d/
+
+ install -d ${D}${bindir}
+ install -m 0755 ${S}/packaging/generic/check-ptp-camera ${D}${bindir}/
+}
+
PACKAGES =+ "libgphotoport libgphoto2-camlibs"
FILES_libgphoto2-camlibs = "${libdir}/libgphoto2*/*/*.so*"
RDEPENDS_${PN} = "libgphoto2-camlibs"
FILES_libgphotoport = "${libdir}/libgphoto2_port.so.*"
-FILES_${PN} += "${libdir}/udev/*"
+FILES_${PN} += "${libdir}/udev/* ${datadir}/hal"
FILES_${PN}-dbg += "${libdir}/*/*/.debug"