aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gphoto2
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-11-28 20:59:53 +0100
committerKoen Kooi <koen@openembedded.org>2009-11-30 10:45:32 +0100
commit68e309c3923cbce4f5ea9449d05ea84e1d21a47c (patch)
tree6bf40d6abace733fd6d8d96c66bc7a143d82c212 /recipes/gphoto2
parent6e0af8778d8938a5a43b8a0e97a0f837bd94fe97 (diff)
downloadopenembedded-68e309c3923cbce4f5ea9449d05ea84e1d21a47c.tar.gz
(lib)gphoto2: update to 2.4.7
Diffstat (limited to 'recipes/gphoto2')
-rw-r--r--recipes/gphoto2/gphoto2_2.4.7.bb15
-rw-r--r--recipes/gphoto2/libgphoto2_2.4.7.bb25
2 files changed, 40 insertions, 0 deletions
diff --git a/recipes/gphoto2/gphoto2_2.4.7.bb b/recipes/gphoto2/gphoto2_2.4.7.bb
new file mode 100644
index 0000000000..8af31d15dc
--- /dev/null
+++ b/recipes/gphoto2/gphoto2_2.4.7.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "gphoto2 is a command-line utility to fetch pictures from digital cameras"
+SECTION = "console/utils"
+LICENSE = "GPL"
+DEPENDS = "libtool libgphoto2 popt"
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/gphoto/gphoto2-${PV}.tar.bz2\
+ file://gphoto-popt-fixup.patch;patch=1"
+
+inherit autotools
+
+do_configure_append() {
+ find ${S} -name Makefile | xargs sed -i 's:/usr/include:${STAGING_INCDIR}:'
+}
+
diff --git a/recipes/gphoto2/libgphoto2_2.4.7.bb b/recipes/gphoto2/libgphoto2_2.4.7.bb
new file mode 100644
index 0000000000..45d42c398c
--- /dev/null
+++ b/recipes/gphoto2/libgphoto2_2.4.7.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "libgphoto2 allows you to access digital cameras"
+SECTION = "libs"
+LICENSE = "GPL"
+DEPENDS = "libtool jpeg virtual/libusb0 libexif"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/gphoto/libgphoto2-${PV}.tar.bz2"
+
+inherit autotools pkgconfig lib_package
+
+OE_LT_RPATH_ALLOW=":${libdir}:"
+OE_LT_RPATH_ALLOW[export]="1"
+
+EXTRA_OECONF = " --with-drivers=all ac_cv_lib_ltdl_lt_dlcaller_register=yes"
+
+PACKAGES =+ "libgphotoport libgphoto2-camlibs"
+FILES_libgphoto2-camlibs = "${libdir}/libgphoto2*/*/*.so*"
+RDEPENDS_${PN} = "libgphoto2-camlibs"
+
+FILES_libgphotoport = "${libdir}/libgphoto2_port.so.*"
+
+FILES_${PN} += "${libdir}/udev/*"
+FILES_${PN}-dbg += "${libdir}/*/*/.debug"
+
+
+