aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gpm/gpm-1.99.7
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2010-06-22 18:41:16 -0700
committerKhem Raj <raj.khem@gmail.com>2010-06-23 13:26:09 -0700
commit339e8ab8375669776d5689220fd48a22737860c7 (patch)
tree540ef1d6441b93401ed100a67f6650f3c623e999 /recipes/gpm/gpm-1.99.7
parentc402cf9096a72e0c2d899d2c131327d2366a418c (diff)
downloadopenembedded-339e8ab8375669776d5689220fd48a22737860c7.tar.gz
gpm-1.99.7: Add recipe.
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/gpm/gpm-1.99.7')
-rw-r--r--recipes/gpm/gpm-1.99.7/init32
-rw-r--r--recipes/gpm/gpm-1.99.7/no-docs.patch18
2 files changed, 50 insertions, 0 deletions
diff --git a/recipes/gpm/gpm-1.99.7/init b/recipes/gpm/gpm-1.99.7/init
new file mode 100644
index 0000000000..f90fce9fc0
--- /dev/null
+++ b/recipes/gpm/gpm-1.99.7/init
@@ -0,0 +1,32 @@
+#! /bin/sh
+
+# Grab the common functions
+#. /etc/init.d/functions
+
+# FIXME:
+# Add a configuration file for GPM here
+
+test -x /usr/sbin/gpm || exit 0
+
+case "$1" in
+ start)
+ if [ ! -p /dev/gpmdata ]; then
+ mkfifo /dev/gpmdata
+ fi
+
+ echo "Starting GPM:"
+ start-stop-daemon -S -x /usr/sbin/gpm -- -R -m /dev/psaux -t ps2
+ ;;
+ stop)
+ echo "Stopping GPM:"
+ start-stop-daemon -K -x /usr/sbin/gpm
+ ;;
+ restart|force-reload)
+ $0 stop
+ $0 start
+ ;;
+ *)
+ usage /etc/init.d/gpm
+esac
+
+exit 0
diff --git a/recipes/gpm/gpm-1.99.7/no-docs.patch b/recipes/gpm/gpm-1.99.7/no-docs.patch
new file mode 100644
index 0000000000..f10217a942
--- /dev/null
+++ b/recipes/gpm/gpm-1.99.7/no-docs.patch
@@ -0,0 +1,18 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+Index: gpm-1.99.7/Makefile.in
+===================================================================
+--- gpm-1.99.7.orig/Makefile.in 2008-07-24 03:36:35.000000000 -0700
++++ gpm-1.99.7/Makefile.in 2010-06-22 18:28:45.269507001 -0700
+@@ -19,7 +19,7 @@
+ # user-overridable flags, but it's also all the implicit rule looks at.
+ # missing ?
+
+-SUBDIRS = src doc contrib gpm2
++SUBDIRS = src
+
+
+ ### simple, but effective rules