aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/grep
diff options
context:
space:
mode:
authorScott Garman <sgarman@zenlinux.com>2010-09-28 06:42:15 +0000
committerKhem Raj <raj.khem@gmail.com>2010-09-30 13:15:07 -0700
commit6ccae1e558a51eb919a59b19e480742b88f1224e (patch)
tree118bd585b9652726cb41028b55b784607c143bd2 /recipes/grep
parent35686bb67b5431e8ff0c2743653279a5e94fffa8 (diff)
downloadopenembedded-6ccae1e558a51eb919a59b19e480742b88f1224e.tar.gz
grep: update 2.6.3 to 2.7
Signed-off-by: Scott Garman <sgarman@zenlinux.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/grep')
-rw-r--r--recipes/grep/grep-2.6.3/uclibc-fix.patch50
-rw-r--r--recipes/grep/grep-2.7/uclibc_libiconv.patch18
-rw-r--r--recipes/grep/grep_2.7.bb (renamed from recipes/grep/grep_2.6.3.bb)29
3 files changed, 31 insertions, 66 deletions
diff --git a/recipes/grep/grep-2.6.3/uclibc-fix.patch b/recipes/grep/grep-2.6.3/uclibc-fix.patch
deleted file mode 100644
index 2e1c584e5a..0000000000
--- a/recipes/grep/grep-2.6.3/uclibc-fix.patch
+++ /dev/null
@@ -1,50 +0,0 @@
-Fix to use mempcpy instead of __mempcpy. This is needed for uclibc which
-doesn't define __mempcpy only mempcpy. Since both uclibc and glibc have
-mempcpy we'll just use that instead.
-
-Index: grep-2.6.3/lib/getopt.c
-===================================================================
---- grep-2.6.3.orig/lib/getopt.c 2010-03-21 00:34:02.000000000 -0700
-+++ grep-2.6.3/lib/getopt.c 2010-05-22 21:37:11.352740539 -0700
-@@ -41,6 +41,10 @@
- # include <wchar.h>
- #endif
-
-+#ifdef __UCLIBC__
-+#define __mempcpy mempcpy
-+#endif
-+
- /* This version of `getopt' appears to the caller like standard Unix `getopt'
- but it behaves differently for the user, since it allows the user
- to intersperse the options with the other arguments.
-Index: grep-2.6.3/gnulib-tests/setenv.c
-===================================================================
---- grep-2.6.3.orig/gnulib-tests/setenv.c 2010-05-22 21:37:53.655168151 -0700
-+++ grep-2.6.3/gnulib-tests/setenv.c 2010-05-22 21:38:42.792745476 -0700
-@@ -68,6 +68,10 @@ __libc_lock_define_initialized (static,
- # define tsearch __tsearch
- #endif
-
-+#ifdef __UCLIBC__
-+#define __mempcpy mempcpy
-+#endif
-+
- /* In the GNU C library implementation we try to be more clever and
- allow arbitrarily many changes of the environment given that the used
- values are from a small set. Outside glibc this will eat up all
-Index: grep-2.6.3/lib/regexec.c
-===================================================================
---- grep-2.6.3.orig/lib/regexec.c 2010-05-22 21:36:02.655154671 -0700
-+++ grep-2.6.3/lib/regexec.c 2010-05-22 21:37:26.212743273 -0700
-@@ -22,6 +22,11 @@
-
- #include "verify.h"
- #include "intprops.h"
-+
-+#ifdef __UCLIBC__
-+#define __mempcpy mempcpy
-+#endif
-+
- static reg_errcode_t match_ctx_init (re_match_context_t *cache, int eflags,
- Idx n) internal_function;
- static void match_ctx_clean (re_match_context_t *mctx) internal_function;
diff --git a/recipes/grep/grep-2.7/uclibc_libiconv.patch b/recipes/grep/grep-2.7/uclibc_libiconv.patch
new file mode 100644
index 0000000000..de83a61eed
--- /dev/null
+++ b/recipes/grep/grep-2.7/uclibc_libiconv.patch
@@ -0,0 +1,18 @@
+# Needed to get grep to build with uclibc.
+# Patch submitted by Bruno Haible to the grep ML on 2010-09-23.
+#
+# Signed-off-by: Scott Garman <sgarman@zenlinux.com>
+diff -ur grep-2.7.orig/src/Makefile.am grep-2.7/src/Makefile.am
+--- grep-2.7.orig/src/Makefile.am 2010-04-04 05:22:24.000000000 -0700
++++ grep-2.7/src/Makefile.am 2010-09-27 21:07:39.370222501 -0700
+@@ -36,7 +36,9 @@
+ # must precede $(LIBINTL) in order to ensure we use GNU getopt.
+ # But libgreputils.a must also follow $(LIBINTL), since libintl uses
+ # replacement functions defined in libgreputils.a.
+-LDADD = libgrep.a ../lib/libgreputils.a $(LIBINTL) ../lib/libgreputils.a
++LDADD = \
++ libgrep.a \
++ ../lib/libgreputils.a $(LIBINTL) ../lib/libgreputils.a $(LIBICONV)
+
+ grep_LDADD = $(LDADD) $(LIB_PCRE)
+ localedir = $(datadir)/locale
diff --git a/recipes/grep/grep_2.6.3.bb b/recipes/grep/grep_2.7.bb
index 25c2a19d86..6267162ce0 100644
--- a/recipes/grep/grep_2.6.3.bb
+++ b/recipes/grep/grep_2.7.bb
@@ -1,19 +1,24 @@
-LICENSE = "GPL"
-SECTION = "console/utils"
DESCRIPTION = "grep GNU utility"
-PR = "r2"
+SECTION = "console/utils"
+HOMEPAGE = "http://savannah.gnu.org/projects/grep/"
+LICENSE = "GPLv3"
+
+PR = "r0"
SRC_URI = "${GNU_MIRROR}/grep/grep-${PV}.tar.gz \
- file://uclibc-fix.patch"
+ file://uclibc_libiconv.patch"
+
+SRC_URI[md5sum] = "e848f07e3e79aa7899345d17c7e4115e"
+SRC_URI[sha256sum] = "ad14831015a79cea36785aa47415f6c0653a6ac4eaf9c15456f0d9d09c9e1bad"
inherit autotools gettext
-EXTRA_OECONF = "--disable-perl-regexp --disable-ncurses"
-EXTRA_OECONF_virtclass-native = "--with-included-regex --disable-ncurses"
+BBCLASSEXTEND = "native"
+
+EXTRA_OECONF = "--disable-perl-regexp"
-do_configure () {
+do_configure_prepend () {
rm -f ${S}/m4/init.m4
- autotools_do_configure
}
do_install () {
@@ -24,10 +29,6 @@ do_install () {
mv ${D}${bindir}/fgrep ${D}${base_bindir}/fgrep.${PN}
}
-do_install_virtclass-native () {
- autotools_do_install
-}
-
pkg_postinst_${PN} () {
update-alternatives --install ${base_bindir}/grep grep grep.${PN} 100
update-alternatives --install ${base_bindir}/egrep egrep egrep.${PN} 100
@@ -39,7 +40,3 @@ pkg_prerm_${PN} () {
update-alternatives --remove egrep egrep.${PN}
update-alternatives --remove fgrep fgrep.${PN}
}
-
-BBCLASSEXTEND = "native"
-SRC_URI[md5sum] = "3095b57837b312f087c0680559de7f13"
-SRC_URI[sha256sum] = "a340e5d1544d9a964072196be627bad3e434ff7a87f3a57ea15aaccbbea4d666"