aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/groff
diff options
context:
space:
mode:
authorMike Westerhof <mwester@dls.net>2011-02-23 14:16:44 -0700
committerTom Rini <tom_rini@mentor.com>2011-02-23 14:19:16 -0700
commit70bf94cd8669f549ca90581e9592d409b6e24e2e (patch)
tree48398ead83056e81cd884f10f512550149864b0c /recipes/groff
parent813a686a451a9a8473473ab1db455abb510cee85 (diff)
downloadopenembedded-70bf94cd8669f549ca90581e9592d409b6e24e2e.tar.gz
groff: Fix do_install in certain cases, along with DEPENDS
Sometimes groff fails in the do_install step, complaining that img/pic* does not exist. Normally, these files would be created by groff itself during the build process, but since we are cross-compiling, the old recipe replaces the invocation of groff and troff with echo commands. However, echo does not create the output files, which eventually results in the do_install failure. This patch makes groff dependent on groff-native, and instead of using echo, it instructs the build process to use the staged groff binaries. (Tom Rini: While in here, switch to GNU_MIRROR) Acked-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Mike Westerhof <mike@mwester.net> Signed-off-by: Tom Rini <tom_rini@mentor.com>
Diffstat (limited to 'recipes/groff')
-rw-r--r--recipes/groff/groff_1.20.1.bb17
1 files changed, 10 insertions, 7 deletions
diff --git a/recipes/groff/groff_1.20.1.bb b/recipes/groff/groff_1.20.1.bb
index 6ea87dce8e..4dd7a3fb20 100644
--- a/recipes/groff/groff_1.20.1.bb
+++ b/recipes/groff/groff_1.20.1.bb
@@ -1,13 +1,16 @@
DESCRIPTION = "GNU roff"
SECTION = "base"
LICENSE = "GPL"
-PR = "r2"
+PR = "r3"
+
+SRC_URI = "${GNU_MIRROR}/groff/groff-${PV}.tar.gz"
-SRC_URI = "http://ftp.gnu.org/gnu/groff/groff-${PV}.tar.gz \
- "
SRC_URI[md5sum] = "48fa768dd6fdeb7968041dd5ae8e2b02"
SRC_URI[sha256sum] = "b645878135cb620c6c417c5601bfe96172245af12045540d7344938b4c2cd805"
+DEPENDS = "groff-native"
+DEPENDS_virtclass-native = ""
+
inherit autotools
PARALLEL_MAKE = ""
@@ -15,10 +18,10 @@ PARALLEL_MAKE = ""
do_configure_prepend(){
if [ "${BUILD_SYS}" != "${HOST_SYS}" ]; then
sed -i \
- -e '/^GROFFBIN=/s:=.*:=echo:' \
- -e '/^TROFFBIN=/s:=.*:=echo:' \
- -e '/^GROFF_BIN_PATH=/s:=.*:=:' \
- -e '/^GROFF_BIN_DIR=/s:=.*:=:' \
+ -e '/^GROFFBIN=/s:=.*:=${STAGING_BINDIR_NATIVE}/groff:' \
+ -e '/^TROFFBIN=/s:=.*:=${STAGING_BINDIR_NATIVE}/troff:' \
+ -e '/^GROFF_BIN_PATH=/s:=.*:=${STAGING_BINDIR_NATIVE}:' \
+ -e '/^GROFF_BIN_DIR=/s:=.*:=${STAGING_BINDIR_NATIVE}:' \
${S}/contrib/*/Makefile.sub \
${S}/doc/Makefile.in \
${S}/doc/Makefile.sub