aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gsl
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/gsl
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/gsl')
-rw-r--r--recipes/gsl/gsl.inc19
-rw-r--r--recipes/gsl/gsl_1.10.bb3
-rw-r--r--recipes/gsl/gsl_1.12.bb3
3 files changed, 25 insertions, 0 deletions
diff --git a/recipes/gsl/gsl.inc b/recipes/gsl/gsl.inc
new file mode 100644
index 0000000000..bc4865c15b
--- /dev/null
+++ b/recipes/gsl/gsl.inc
@@ -0,0 +1,19 @@
+DESCRIPTION = "GNU Scientific Library"
+HOMEPAGE = "http://www.gnu.org/software/gsl/"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "GPL"
+PR = "r0"
+
+inherit autotools pkgconfig binconfig
+
+LEAD_SONAME = "libgsl.so"
+
+do_stage() {
+ oe_runmake DESTDIR=${S}/.install install
+ oe_libinstall -so -C cblas/.libs/ libgslcblas ${STAGING_LIBDIR}
+ oe_libinstall -so -C .libs/ libgsl ${STAGING_LIBDIR}
+
+ install -d ${STAGING_INCDIR}/gsl
+ install -m 0644 .install${includedir}/gsl/* ${STAGING_INCDIR}/gsl
+}
diff --git a/recipes/gsl/gsl_1.10.bb b/recipes/gsl/gsl_1.10.bb
new file mode 100644
index 0000000000..8ebe5304c4
--- /dev/null
+++ b/recipes/gsl/gsl_1.10.bb
@@ -0,0 +1,3 @@
+include gsl.inc
+
+SRC_URI = "${GNU_MIRROR}/gsl/gsl-${PV}.tar.gz"
diff --git a/recipes/gsl/gsl_1.12.bb b/recipes/gsl/gsl_1.12.bb
new file mode 100644
index 0000000000..8ebe5304c4
--- /dev/null
+++ b/recipes/gsl/gsl_1.12.bb
@@ -0,0 +1,3 @@
+include gsl.inc
+
+SRC_URI = "${GNU_MIRROR}/gsl/gsl-${PV}.tar.gz"