aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gsoko
diff options
context:
space:
mode:
authorFlorian Boor <florian.boor@kernelconcepts.de>2009-05-12 15:20:35 +0200
committerFlorian Boor <florian.boor@kernelconcepts.de>2009-05-12 15:22:49 +0200
commitb5f722ac2fc7438c987ef0a621aa671987397c8e (patch)
tree4ee2a82a67981bffad6ef6cce23be127eed32836 /recipes/gsoko
parent6349eba5e10c3f8d78dede7e15abf3dec897a374 (diff)
downloadopenembedded-b5f722ac2fc7438c987ef0a621aa671987397c8e.tar.gz
gsoko: Apply fix to suppress strip installing binary.
Diffstat (limited to 'recipes/gsoko')
-rw-r--r--recipes/gsoko/gsoko-0.4.2-gpe6/fix_install.patch13
-rw-r--r--recipes/gsoko/gsoko_0.4.2-gpe6.bb5
2 files changed, 17 insertions, 1 deletions
diff --git a/recipes/gsoko/gsoko-0.4.2-gpe6/fix_install.patch b/recipes/gsoko/gsoko-0.4.2-gpe6/fix_install.patch
new file mode 100644
index 0000000000..6187e2ad02
--- /dev/null
+++ b/recipes/gsoko/gsoko-0.4.2-gpe6/fix_install.patch
@@ -0,0 +1,13 @@
+diff --git gsoko-0.4.2-gpe6/Makefile-orig gsoko-0.4.2-gpe6/Makefile
+index 1db0ce7..d36392a 100644
+--- gsoko-0.4.2-gpe6/Makefile-orig
++++ gsoko-0.4.2-gpe6/Makefile
+@@ -29,7 +29,7 @@ IMGS = box.png box2.png man.png tile.png tile2.png wall.png
+
+ install-program: gsoko gsoko.desktop
+ install -d $(DESTDIR)$(PREFIX)/bin
+- install -s gsoko $(DESTDIR)$(PREFIX)/bin/gsoko
++ install gsoko $(DESTDIR)$(PREFIX)/bin/gsoko
+ install -d $(DESTDIR)$(PREFIX)/share/gsoko/img
+ install -d $(DESTDIR)$(PREFIX)/share/gsoko/levels
+ for i in $(LEVELS); do install -m 644 levels/$$i.lev $(DESTDIR)$(PREFIX)/share/gsoko/levels/$$i.lev; done
diff --git a/recipes/gsoko/gsoko_0.4.2-gpe6.bb b/recipes/gsoko/gsoko_0.4.2-gpe6.bb
index 6a34be2bc4..f1a513c40c 100644
--- a/recipes/gsoko/gsoko_0.4.2-gpe6.bb
+++ b/recipes/gsoko/gsoko_0.4.2-gpe6.bb
@@ -6,4 +6,7 @@ DESCRIPTION = "Sokoban game for GTK"
PRIORITY = "optional"
PR = "r1"
-SRC_URI += "file://fix_makefiles.patch;patch=1"
+SRC_URI += " \
+ file://fix_makefiles.patch;patch=1 \
+ file://fix_install.patch;patch=1 \
+ "