aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gspcav1
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/gspcav1
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/gspcav1')
-rw-r--r--recipes/gspcav1/files/MS.patch29
-rw-r--r--recipes/gspcav1/files/Makefile.patch11
-rw-r--r--recipes/gspcav1/gspcav1/Makefile-fix-cc-quoting.diff11
-rw-r--r--recipes/gspcav1/gspcav1_20070110.bb29
-rw-r--r--recipes/gspcav1/gspcav1_20070508.bb31
-rw-r--r--recipes/gspcav1/gspcav1_20071224.bb25
6 files changed, 136 insertions, 0 deletions
diff --git a/recipes/gspcav1/files/MS.patch b/recipes/gspcav1/files/MS.patch
new file mode 100644
index 0000000000..588a4bc3da
--- /dev/null
+++ b/recipes/gspcav1/files/MS.patch
@@ -0,0 +1,29 @@
+--- gspcav1-20070110/gspca_core.c.orig 2007-03-16 23:24:37.000000000 +0000
++++ gspcav1-20070110/gspca_core.c 2007-03-16 23:24:43.000000000 +0000
+@@ -398,7 +398,7 @@
+ Sonyc002,
+ Vimicro0321,
+ Orbicam,
+- M$VX1000,
++ MSVX1000,
+ Trust610LCDPowerCamZoom,
+ Sonyc001,
+ LastCamera
+@@ -580,7 +580,7 @@
+ {Sonyc002,"Vc0321"},
+ {Vimicro0321,"Vc0321"},
+ {Orbicam,"Logitech Orbicam"},
+- {M$VX1000,"MicroSoft VX1000"},
++ {MSVX1000,"MicroSoft VX1000"},
+ {Trust610LCDPowerCamZoom, "Trust 610 LCD PowerC@m Zoom"},
+ {Sonyc001,"Sony Visual Communication VGP-VCC1"},
+ {-1, NULL}
+@@ -3124,7 +3124,7 @@
+ case 0x045e:
+ switch(product){
+ case 0x00f7:
+- spca50x->desc = M$VX1000;
++ spca50x->desc = MSVX1000;
+ spca50x->bridge = BRIDGE_SN9CXXX;
+ spca50x->sensor = SENSOR_OV7660;
+ spca50x->customid = SN9C105;
diff --git a/recipes/gspcav1/files/Makefile.patch b/recipes/gspcav1/files/Makefile.patch
new file mode 100644
index 0000000000..87262686cb
--- /dev/null
+++ b/recipes/gspcav1/files/Makefile.patch
@@ -0,0 +1,11 @@
+--- gspcav1-20070110/Makefile.orig 2007-03-16 23:20:18.000000000 +0000
++++ gspcav1-20070110/Makefile 2007-03-16 23:20:44.000000000 +0000
+@@ -41,7 +41,7 @@
+ MODULE_INSTALLDIR2 = /lib/modules/$(KERNEL_VERSION)/kernel/drivers/media/video/
+
+ default:
+- $(MAKE) -C $(KERNELDIR) SUBDIRS=$(PWD) CC=$(CC) modules
++ $(MAKE) -C $(KERNELDIR) SUBDIRS=$(PWD) CC="$(CC)" modules
+
+ install:
+ mkdir -p $(MODULE_INSTALLDIR)
diff --git a/recipes/gspcav1/gspcav1/Makefile-fix-cc-quoting.diff b/recipes/gspcav1/gspcav1/Makefile-fix-cc-quoting.diff
new file mode 100644
index 0000000000..6f04069e0f
--- /dev/null
+++ b/recipes/gspcav1/gspcav1/Makefile-fix-cc-quoting.diff
@@ -0,0 +1,11 @@
+--- /tmp/Makefile 2008-11-20 10:11:25.000000000 +0100
++++ gspcav1-20071224/Makefile 2008-11-20 10:11:45.000000000 +0100
+@@ -41,7 +41,7 @@
+ MODULE_INSTALLDIR2 = /lib/modules/$(KERNEL_VERSION)/kernel/drivers/media/video/
+
+ default:
+- $(MAKE) -C $(KERNELDIR) SUBDIRS=$(PWD) CC=$(CC) modules
++ $(MAKE) -C $(KERNELDIR) SUBDIRS=$(PWD) CC="$(CC)" modules
+
+ install:
+ mkdir -p $(MODULE_INSTALLDIR)
diff --git a/recipes/gspcav1/gspcav1_20070110.bb b/recipes/gspcav1/gspcav1_20070110.bb
new file mode 100644
index 0000000000..40a99d9bd9
--- /dev/null
+++ b/recipes/gspcav1/gspcav1_20070110.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "USB Webcam driver for spca5xx chipset family supporting \
+over 100 models of camera"
+PRIORITY = "optional"
+SECTION = "kernel/modules"
+LICENSE = "GPL"
+
+PR = "r2"
+
+RRECOMMENDS = "kernel-module-videodev kernel-module-v4l1-compat kernel-module-v4l2-common"
+
+SRC_URI = "http://mxhaard.free.fr/spca50x/Download/oldrelease/${PN}-${PV}.tar.gz \
+ file://Makefile.patch;patch=1 \
+ file://MS.patch;patch=1"
+
+S = "${WORKDIR}/${PN}-${PV}"
+
+inherit module
+
+do_compile () {
+ unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
+ oe_runmake 'KERNELDIR=${STAGING_KERNEL_DIR}' \
+ 'CC=${KERNEL_CC}' \
+ 'LD=${KERNEL_LD}'
+}
+
+do_install() {
+ install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/usb/media
+ install -m 0644 *${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/usb/media
+}
diff --git a/recipes/gspcav1/gspcav1_20070508.bb b/recipes/gspcav1/gspcav1_20070508.bb
new file mode 100644
index 0000000000..866d32b86a
--- /dev/null
+++ b/recipes/gspcav1/gspcav1_20070508.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "USB Webcam driver for spca5xx chipset family supporting \
+over 100 models of camera"
+PRIORITY = "optional"
+SECTION = "kernel/modules"
+LICENSE = "GPL"
+
+DEFAULT_PREFERENCE = "-1"
+
+PR = "r2"
+
+RRECOMMENDS = "kernel-module-videodev kernel-module-v4l1-compat kernel-module-v4l2-common"
+
+SRC_URI = "http://mxhaard.free.fr/spca50x/Download/oldrelease/${PN}-${PV}.tar.gz \
+ file://Makefile.patch;patch=1 \
+ file://MS.patch;patch=1"
+
+S = "${WORKDIR}/${PN}-${PV}"
+
+inherit module
+
+do_compile () {
+ unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
+ oe_runmake 'KERNELDIR=${STAGING_KERNEL_DIR}' \
+ 'CC=${KERNEL_CC}' \
+ 'LD=${KERNEL_LD}'
+}
+
+do_install() {
+ install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/usb/media
+ install -m 0644 *${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/usb/media
+}
diff --git a/recipes/gspcav1/gspcav1_20071224.bb b/recipes/gspcav1/gspcav1_20071224.bb
new file mode 100644
index 0000000000..c6ab5f689e
--- /dev/null
+++ b/recipes/gspcav1/gspcav1_20071224.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "USB Webcam driver for spca5xx chipset family supporting \
+over 100 models of camera"
+PRIORITY = "optional"
+SECTION = "kernel/modules"
+LICENSE = "GPL"
+
+SRC_URI = "http://mxhaard.free.fr/spca50x/Download/gspcav1-${PV}.tar.gz \
+ file://Makefile-fix-cc-quoting.diff;patch=1 \
+ "
+
+S = "${WORKDIR}/gspcav1-${PV}"
+
+inherit module
+
+do_compile () {
+ unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
+ oe_runmake 'KERNELDIR=${STAGING_KERNEL_DIR}' \
+ 'CC=${KERNEL_CC}' \
+ 'LD=${KERNEL_LD}'
+}
+
+do_install() {
+ install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/usb/media
+ install -m 0644 *${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/usb/media
+}