aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gstreamer/gst-ffmpeg_0.10.4.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2010-08-05 19:37:35 -0400
committerDenys Dmytriyenko <denis@denix.org>2010-08-05 19:50:21 -0400
commit7c376183bb70d404e7a9bb4d31552f80de91927a (patch)
tree151c7e63240bfbc6a68ca9c98cf1f76983a04d47 /recipes/gstreamer/gst-ffmpeg_0.10.4.bb
parent34f2f07769fe31db2a2224183377c9ff27c886f7 (diff)
downloadopenembedded-7c376183bb70d404e7a9bb4d31552f80de91927a.tar.gz
gst-ffmpeg: use immediate var expansion of TOOLCHAIN_PATH for PATH_prepend
Fixes the recursive var expansion when TOOLCHAIN_PATH is derived from PATH. Signed-off-by: Denys Dmytriyenko <denis@denix.org>
Diffstat (limited to 'recipes/gstreamer/gst-ffmpeg_0.10.4.bb')
-rw-r--r--recipes/gstreamer/gst-ffmpeg_0.10.4.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes/gstreamer/gst-ffmpeg_0.10.4.bb b/recipes/gstreamer/gst-ffmpeg_0.10.4.bb
index 83ccdb550e..a80c8ddabe 100644
--- a/recipes/gstreamer/gst-ffmpeg_0.10.4.bb
+++ b/recipes/gstreamer/gst-ffmpeg_0.10.4.bb
@@ -24,7 +24,7 @@ EXTRA_OECONF = "--disable-sdltest --disable-ffplay --disable-freetypetest \
# We do this because the install program is called with -s which causes it to
# call "strip" and it then mangles cross compiled stuff..
-PATH_prepend="${TOOLCHAIN_PATH}/${TARGET_SYS}/bin:"
+PATH_prepend := "${TOOLCHAIN_PATH}/${TARGET_SYS}/bin:"
# Hack to get STAGING_LIBDIR into the linker path when building ffmpeg
CC = "${CCACHE} ${HOST_PREFIX}gcc ${TARGET_CC_ARCH} -L${STAGING_LIBDIR}"