aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gstreamer/gst-plugin-bc_git.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-03-08 12:48:52 +0100
committerKoen Kooi <koen@openembedded.org>2010-03-08 12:51:20 +0100
commit4b674c46ac973b4f6216ef6d6e1069dbdbc773c7 (patch)
treebd573c77c173da826ce9c8644fc3f9ce067d07be /recipes/gstreamer/gst-plugin-bc_git.bb
parent56631534045bf91cb47253ba08d0dfcd93b68e69 (diff)
downloadopenembedded-4b674c46ac973b4f6216ef6d6e1069dbdbc773c7.tar.gz
gst-plugin-bc: add git version
Diffstat (limited to 'recipes/gstreamer/gst-plugin-bc_git.bb')
-rw-r--r--recipes/gstreamer/gst-plugin-bc_git.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes/gstreamer/gst-plugin-bc_git.bb b/recipes/gstreamer/gst-plugin-bc_git.bb
new file mode 100644
index 0000000000..b27c47e63a
--- /dev/null
+++ b/recipes/gstreamer/gst-plugin-bc_git.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "GStreamer elements for IMG BufferClass API"
+LICENSE = "GPLv3"
+
+PV = "0.10.1.1"
+PR = "r1"
+PR_append = "+gitr${SRCREV}"
+
+inherit autotools
+
+SRC_URI = "git://gitorious.org/gst-plugin-bc/gst-plugin-bc.git;protocol=git \
+ http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-0.10.25.tar.bz2 \
+ file://gst-debug.diff;patch=1 \
+"
+
+SRCREV = "e14e249ef6cb67e91be9198b71efc61eb84c11b5"
+
+S = "${WORKDIR}/git"
+
+EXTRA_OECONF = " --enable-gles2-example "
+
+# bitbake git fetcher doesn't handle git submodules currently
+do_configure_prepend () {
+ cp -rf ${WORKDIR}/gstreamer-0.10.25/common/* ${S}/common/
+ autopoint
+}
+
+ALLOW_EMPTY = "1"
+
+require gst-plugins-package.inc
+