aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gstreamer/gstreamer
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/gstreamer/gstreamer
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/gstreamer/gstreamer')
-rw-r--r--recipes/gstreamer/gstreamer/configure-largefile.patch13
-rw-r--r--recipes/gstreamer/gstreamer/filesrc-uri.patch22
-rw-r--r--recipes/gstreamer/gstreamer/gstreamer.xsession4
-rw-r--r--recipes/gstreamer/gstreamer/po-makefile-fix.patch12
-rw-r--r--recipes/gstreamer/gstreamer/registry-do-not-look-into-debug-dirs.patch39
5 files changed, 90 insertions, 0 deletions
diff --git a/recipes/gstreamer/gstreamer/configure-largefile.patch b/recipes/gstreamer/gstreamer/configure-largefile.patch
new file mode 100644
index 0000000000..6ea1ef3dba
--- /dev/null
+++ b/recipes/gstreamer/gstreamer/configure-largefile.patch
@@ -0,0 +1,13 @@
+--- configure.ac~ 2004-06-03 12:37:47.000000000 +0100
++++ configure.ac 2004-06-04 13:31:02.000000000 +0100
+@@ -172,6 +172,10 @@
+ ],
+ [
+ AC_MSG_RESULT(no)
++],
++[
++ AC_MSG_RESULT(cross-compiling, assumed yes)
++ GST_PKG_CFLAGS="-D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64"
+ ])
+
+ dnl check for mmap
diff --git a/recipes/gstreamer/gstreamer/filesrc-uri.patch b/recipes/gstreamer/gstreamer/filesrc-uri.patch
new file mode 100644
index 0000000000..0bde73d970
--- /dev/null
+++ b/recipes/gstreamer/gstreamer/filesrc-uri.patch
@@ -0,0 +1,22 @@
+Index: gst/elements/gstfilesrc.c
+===================================================================
+RCS file: /cvs/gstreamer/gstreamer/gst/elements/gstfilesrc.c,v
+retrieving revision 1.108.4.3
+diff -u -r1.108.4.3 gstfilesrc.c
+--- gstreamer.orig/gst/elements/gstfilesrc.c 3 Jun 2005 09:29:31 -0000 1.108.4.3
++++ gstreamer/gst/elements/gstfilesrc.c 12 Aug 2005 11:54:38 -0000
+@@ -306,7 +306,13 @@
+ src->filename = NULL;
+ src->uri = NULL;
+ } else {
+- src->filename = g_strdup (location);
++ const gchar *file_prefix = "file://";
++
++ if (g_str_has_prefix (location, file_prefix)) {
++ src->filename = g_strdup (location + strlen (file_prefix));
++ } else {
++ src->filename = g_strdup (location);
++ }
+ src->uri = gst_uri_construct ("file", src->filename);
+ }
+ g_object_notify (G_OBJECT (src), "location");
diff --git a/recipes/gstreamer/gstreamer/gstreamer.xsession b/recipes/gstreamer/gstreamer/gstreamer.xsession
new file mode 100644
index 0000000000..a260a8d142
--- /dev/null
+++ b/recipes/gstreamer/gstreamer/gstreamer.xsession
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+gst-register
+
diff --git a/recipes/gstreamer/gstreamer/po-makefile-fix.patch b/recipes/gstreamer/gstreamer/po-makefile-fix.patch
new file mode 100644
index 0000000000..1cf665e2db
--- /dev/null
+++ b/recipes/gstreamer/gstreamer/po-makefile-fix.patch
@@ -0,0 +1,12 @@
+diff -urN gstreamer-0.10.17.orig/po/Makefile.in.in gstreamer-0.10.17/po/Makefile.in.in
+--- gstreamer-0.10.17.orig/po/Makefile.in.in 2008-01-25 16:21:31.000000000 +0100
++++ gstreamer-0.10.17/po/Makefile.in.in 2008-09-08 14:41:21.000000000 +0200
+@@ -30,7 +30,7 @@
+ INSTALL = @INSTALL@
+ INSTALL_DATA = @INSTALL_DATA@
+ MKINSTALLDIRS = @MKINSTALLDIRS@
+-mkinstalldirs = $(SHELL) `case "$(MKINSTALLDIRS)" in /*) echo "$(MKINSTALLDIRS)" ;; *) echo "$(top_builddir)/$(MKINSTALLDIRS)" ;; esac`
++mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
+
+ GMSGFMT = @GMSGFMT@
+ MSGFMT = @MSGFMT@
diff --git a/recipes/gstreamer/gstreamer/registry-do-not-look-into-debug-dirs.patch b/recipes/gstreamer/gstreamer/registry-do-not-look-into-debug-dirs.patch
new file mode 100644
index 0000000000..6733e6be06
--- /dev/null
+++ b/recipes/gstreamer/gstreamer/registry-do-not-look-into-debug-dirs.patch
@@ -0,0 +1,39 @@
+Work around a glibc 2.6.1 bug with dlopen. We try to dlopen a .so file that
+only contains debug symbols (e.g. no architecture is set in the elf header)
+
+
+#0 0x4000a88c in _dl_relocate_object () from /lib/ld-linux.so.3
+(gdb) bt
+#0 0x4000a88c in _dl_relocate_object () from /lib/ld-linux.so.3
+#1 0x40011f68 in dl_open_worker () from /lib/ld-linux.so.3
+#2 0x4000d7e4 in _dl_catch_error () from /lib/ld-linux.so.3
+#3 0x400117d8 in _dl_open () from /lib/ld-linux.so.3
+#4 0x402fba84 in dlopen_doit () from /lib/libdl.so.2
+#5 0x4000d7e4 in _dl_catch_error () from /lib/ld-linux.so.3
+#6 0x402fbf50 in _dlerror_run () from /lib/libdl.so.2
+#7 0x402fb9bc in dlopen@@GLIBC_2.4 () from /lib/libdl.so.2
+#8 0x402f2790 in g_module_open () from /usr/lib/libgmodule-2.0.so.0
+#9 0x40078784 in gst_plugin_load_file (
+ filename=0x10a6c8 "/usr/lib/gstreamer-0.10/.debug/libgstcoreindexers.so",
+ error=0x0) at gstplugin.c:481
+#10 0x4007e3c4 in gst_registry_scan_path_level (registry=0x27828,
+ path=0x10a6a0 "/usr/lib/gstreamer-0.10/.debug", level=1) at gstregistry.c:891
+#11 0x4007df04 in gst_registry_scan_path_level (registry=0x27828,
+
+
+Index: gstreamer-0.10.17/gst/gstregistry.c
+===================================================================
+--- gstreamer-0.10.17.orig/gst/gstregistry.c 2008-11-14 23:30:48.000000000 +0100
++++ gstreamer-0.10.17/gst/gstregistry.c 2008-11-14 23:32:39.000000000 +0100
+@@ -813,7 +813,10 @@
+ GST_LOG_OBJECT (registry, "examining file: %s", filename);
+
+ if (g_file_test (filename, G_FILE_TEST_IS_DIR)) {
+- if (level > 0) {
++ if (g_str_has_suffix (filename, ".debug")) {
++ GST_LOG_OBJECT (registry,
++ "found directory, not descending into .debug directory");
++ } else if (level > 0) {
+ GST_LOG_OBJECT (registry, "found directory, recursing");
+ changed |= gst_registry_scan_path_level (registry, filename, level - 1);
+ } else {