aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gstreamer
diff options
context:
space:
mode:
authorStanislav Brabec <utx@penguin.cz>2009-03-30 20:54:33 +0000
committerutx@penguin.cz <utx@penguin.cz>2009-03-30 20:56:19 +0000
commita021ada0a72025308237b60dc960aea813cfba86 (patch)
treef02215aa9b205672ebd5d449a3fe4f5ff32c91e8 /recipes/gstreamer
parent9fdd2e01e2f849aa6677dc6c1ec8e48444235c11 (diff)
downloadopenembedded-a021ada0a72025308237b60dc960aea813cfba86.tar.gz
gst-ffmpeg: Updated to version 0.10.7.
Diffstat (limited to 'recipes/gstreamer')
-rw-r--r--recipes/gstreamer/gst-ffmpeg-0.10.7/configure-hack.diff12
-rw-r--r--recipes/gstreamer/gst-ffmpeg_0.10.7.bb32
2 files changed, 44 insertions, 0 deletions
diff --git a/recipes/gstreamer/gst-ffmpeg-0.10.7/configure-hack.diff b/recipes/gstreamer/gst-ffmpeg-0.10.7/configure-hack.diff
new file mode 100644
index 0000000000..874ba57777
--- /dev/null
+++ b/recipes/gstreamer/gst-ffmpeg-0.10.7/configure-hack.diff
@@ -0,0 +1,12 @@
+Index: gst-ffmpeg-0.10.7/configure.ac
+===================================================================
+--- gst-ffmpeg-0.10.7.orig/configure.ac 2009-03-21 00:44:01.000000000 +0000
++++ gst-ffmpeg-0.10.7/configure.ac 2009-03-30 20:45:05.000000000 +0000
+@@ -337,7 +337,6 @@
+ AC_SUBST(FFMPEG_SVN)
+ AC_SUBST(FFMPEG_REVISION)
+ AC_SUBST(FFMPEG_EXTERNALS_REVISION)
+- AC_CONFIG_SUBDIRS(gst-libs/ext/ffmpeg)
+ AC_MSG_NOTICE([Using included FFMpeg code])
+ fi
+
diff --git a/recipes/gstreamer/gst-ffmpeg_0.10.7.bb b/recipes/gstreamer/gst-ffmpeg_0.10.7.bb
new file mode 100644
index 0000000000..20cea128dd
--- /dev/null
+++ b/recipes/gstreamer/gst-ffmpeg_0.10.7.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "FFmpeg-based GStreamer plug-in"
+SECTION = "multimedia"
+PRIORITY = "optional"
+LICENSE = "LGPL"
+HOMEPAGE = "http://www.gstreamer.net/"
+DEPENDS = "ffmpeg gstreamer gst-plugins-base zlib"
+PR = "r1"
+
+inherit autotools pkgconfig
+
+SRC_URI = "http://gstreamer.freedesktop.org/src/${PN}/${PN}-${PV}.tar.bz2 \
+ file://configure-hack.diff;patch=1 \
+ file://lower-rank.diff;patch=1 \
+"
+
+FILES_${PN} += "${libdir}/gstreamer-0.10/*.so"
+FILES_${PN}-dbg += "${libdir}/gstreamer-0.10/.debug"
+FILES_${PN}-dev += "${libdir}/gstreamer-0.10/*.la ${libdir}/gstreamer-0.10/*.a"
+
+EXTRA_OECONF = "--disable-sdltest --disable-ffplay --disable-freetypetest \
+ --disable-vorbis --disable-vorbistest --disable-encoders \
+ --disable-v4l --disable-audio-oss --disable-dv1394 \
+ --disable-vhook --with-system-ffmpeg --disable-ffserver \
+ --enable-pp --disable-decoder-vorbis"
+
+# We do this because the install program is called with -s which causes it to
+# call "strip" and it then mangles cross compiled stuff..
+PATH_prepend="${CROSS_DIR}/${TARGET_SYS}/bin:"
+
+# Hack to get STAGING_LIBDIR into the linker path when building ffmpeg
+CC = "${CCACHE} ${HOST_PREFIX}gcc ${TARGET_CC_ARCH} -L${STAGING_LIBDIR}"
+