summaryrefslogtreecommitdiffstats
path: root/recipes/gstreamer
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2010-07-30 13:40:40 -0700
committerKhem Raj <raj.khem@gmail.com>2010-08-03 12:46:05 -0700
commit713508343d70a31ccfe1bdee7fee8038e65b8c40 (patch)
tree37f5d14a294da3f59e4087d75e3fa20db347c45a /recipes/gstreamer
parent07733978e28ec682fbabac61325fe3dc22d6dbda (diff)
downloadopenembedded-713508343d70a31ccfe1bdee7fee8038e65b8c40.tar.gz
recipes: Fix the PATHs for toolchains.
* Look into the new multi-machine friendly installation. Signed-off-by: Khem Raj <raj.khem@gmail.com> Acked-by: Koen Kooi <k-kooi@ti.com> Acked-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/gstreamer')
-rw-r--r--recipes/gstreamer/gst-ffmpeg_0.10.10.bb2
-rw-r--r--recipes/gstreamer/gst-ffmpeg_0.10.2.bb2
-rw-r--r--recipes/gstreamer/gst-ffmpeg_0.10.4.bb2
-rw-r--r--recipes/gstreamer/gst-ffmpeg_0.10.6.bb2
-rw-r--r--recipes/gstreamer/gst-ffmpeg_0.10.7.bb2
-rw-r--r--recipes/gstreamer/gst-ffmpeg_0.10.8.bb2
6 files changed, 6 insertions, 6 deletions
diff --git a/recipes/gstreamer/gst-ffmpeg_0.10.10.bb b/recipes/gstreamer/gst-ffmpeg_0.10.10.bb
index d2b6901793..0952683f50 100644
--- a/recipes/gstreamer/gst-ffmpeg_0.10.10.bb
+++ b/recipes/gstreamer/gst-ffmpeg_0.10.10.bb
@@ -24,7 +24,7 @@ EXTRA_OECONF = " --with-system-ffmpeg "
# We do this because the install program is called with -s which causes it to
# call "strip" and it then mangles cross compiled stuff..
-PATH_prepend="${STAGING_DIR_NATIVE}${prefix_native}/${TARGET_SYS}/bin:"
+PATH_prepend="${TOOLCHAIN_PATH}/${TARGET_SYS}/bin:"
# Hack to get STAGING_LIBDIR into the linker path when building ffmpeg
CC = "${CCACHE} ${HOST_PREFIX}gcc ${TARGET_CC_ARCH} -L${STAGING_LIBDIR}"
diff --git a/recipes/gstreamer/gst-ffmpeg_0.10.2.bb b/recipes/gstreamer/gst-ffmpeg_0.10.2.bb
index f2c265416f..2328b0d085 100644
--- a/recipes/gstreamer/gst-ffmpeg_0.10.2.bb
+++ b/recipes/gstreamer/gst-ffmpeg_0.10.2.bb
@@ -25,7 +25,7 @@ EXTRA_OECONF = "--disable-sdltest --disable-ffplay --disable-freetypetest \
# We do this because the install program is called with -s which causes it to
# call "strip" and it then mangles cross compiled stuff..
-PATH_prepend="${STAGING_DIR_NATIVE}${prefix_native}/${TARGET_SYS}/bin:"
+PATH_prepend="${TOOLCHAIN_PATH}/${TARGET_SYS}/bin:"
# Hack to get STAGING_LIBDIR into the linker path when building ffmpeg
CC = "${CCACHE} ${HOST_PREFIX}gcc ${TARGET_CC_ARCH} -L${STAGING_LIBDIR}"
diff --git a/recipes/gstreamer/gst-ffmpeg_0.10.4.bb b/recipes/gstreamer/gst-ffmpeg_0.10.4.bb
index 28a753d8f2..83ccdb550e 100644
--- a/recipes/gstreamer/gst-ffmpeg_0.10.4.bb
+++ b/recipes/gstreamer/gst-ffmpeg_0.10.4.bb
@@ -24,7 +24,7 @@ EXTRA_OECONF = "--disable-sdltest --disable-ffplay --disable-freetypetest \
# We do this because the install program is called with -s which causes it to
# call "strip" and it then mangles cross compiled stuff..
-PATH_prepend="${STAGING_DIR_NATIVE}${prefix_native}/${TARGET_SYS}/bin:"
+PATH_prepend="${TOOLCHAIN_PATH}/${TARGET_SYS}/bin:"
# Hack to get STAGING_LIBDIR into the linker path when building ffmpeg
CC = "${CCACHE} ${HOST_PREFIX}gcc ${TARGET_CC_ARCH} -L${STAGING_LIBDIR}"
diff --git a/recipes/gstreamer/gst-ffmpeg_0.10.6.bb b/recipes/gstreamer/gst-ffmpeg_0.10.6.bb
index 9b8ec8dcae..c78b4c49a1 100644
--- a/recipes/gstreamer/gst-ffmpeg_0.10.6.bb
+++ b/recipes/gstreamer/gst-ffmpeg_0.10.6.bb
@@ -25,7 +25,7 @@ EXTRA_OECONF = "--disable-sdltest --disable-ffplay --disable-freetypetest \
# We do this because the install program is called with -s which causes it to
# call "strip" and it then mangles cross compiled stuff..
-PATH_prepend="${STAGING_DIR_NATIVE}${prefix_native}/${TARGET_SYS}/bin:"
+PATH_prepend="${TOOLCHAIN_PATH}/${TARGET_SYS}/bin:"
# Hack to get STAGING_LIBDIR into the linker path when building ffmpeg
CC = "${CCACHE} ${HOST_PREFIX}gcc ${TARGET_CC_ARCH} -L${STAGING_LIBDIR}"
diff --git a/recipes/gstreamer/gst-ffmpeg_0.10.7.bb b/recipes/gstreamer/gst-ffmpeg_0.10.7.bb
index 8a1d56edb5..a8bbbec507 100644
--- a/recipes/gstreamer/gst-ffmpeg_0.10.7.bb
+++ b/recipes/gstreamer/gst-ffmpeg_0.10.7.bb
@@ -25,7 +25,7 @@ EXTRA_OECONF = "--disable-sdltest --disable-ffplay --disable-freetypetest \
# We do this because the install program is called with -s which causes it to
# call "strip" and it then mangles cross compiled stuff..
-PATH_prepend="${STAGING_DIR_NATIVE}${prefix_native}/${TARGET_SYS}/bin:"
+PATH_prepend="${TOOLCHAIN_PATH}/${TARGET_SYS}/bin:"
# Hack to get STAGING_LIBDIR into the linker path when building ffmpeg
CC = "${CCACHE} ${HOST_PREFIX}gcc ${TARGET_CC_ARCH} -L${STAGING_LIBDIR}"
diff --git a/recipes/gstreamer/gst-ffmpeg_0.10.8.bb b/recipes/gstreamer/gst-ffmpeg_0.10.8.bb
index 0cd0cebf87..5f92dcc64a 100644
--- a/recipes/gstreamer/gst-ffmpeg_0.10.8.bb
+++ b/recipes/gstreamer/gst-ffmpeg_0.10.8.bb
@@ -21,7 +21,7 @@ EXTRA_OECONF = " --with-system-ffmpeg "
# We do this because the install program is called with -s which causes it to
# call "strip" and it then mangles cross compiled stuff..
-PATH_prepend="${STAGING_DIR_NATIVE}${prefix_native}/${TARGET_SYS}/bin:"
+PATH_prepend="${TOOLCHAIN_PATH}/${TARGET_SYS}/bin:"
# Hack to get STAGING_LIBDIR into the linker path when building ffmpeg
CC = "${CCACHE} ${HOST_PREFIX}gcc ${TARGET_CC_ARCH} -L${STAGING_LIBDIR}"