aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gstreamer
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2011-02-25 07:39:18 +0000
committerDenys Dmytriyenko <denys@ti.com>2011-02-24 21:05:56 -0500
commit47a8210e4a9a6987501cd37b046cbc320493356f (patch)
tree65195ed02f1436a7d7e0fe429b2d12ad70bd284c /recipes/gstreamer
parent93bb226b98706b22c952a1a49981d5066abbf3c1 (diff)
downloadopenembedded-47a8210e4a9a6987501cd37b046cbc320493356f.tar.gz
gst-ffmpeg: remove 4-year old hack that sets CC directly
The hack that sets CC variable directly is 4 year old and no longer required. On the other hand, it now breaks setups when --sysroot needs to be passed to the toolchain. Hence, remove the hack. Signed-off-by: Denys Dmytriyenko <denys@ti.com> Acked-by: Tom Rini <tom_rini@mentor.com>
Diffstat (limited to 'recipes/gstreamer')
-rw-r--r--recipes/gstreamer/gst-ffmpeg_0.10.11.bb6
1 files changed, 2 insertions, 4 deletions
diff --git a/recipes/gstreamer/gst-ffmpeg_0.10.11.bb b/recipes/gstreamer/gst-ffmpeg_0.10.11.bb
index 3a6533a9dd..563521e7c4 100644
--- a/recipes/gstreamer/gst-ffmpeg_0.10.11.bb
+++ b/recipes/gstreamer/gst-ffmpeg_0.10.11.bb
@@ -5,6 +5,8 @@ LICENSE = "LGPL"
HOMEPAGE = "http://www.gstreamer.net/"
DEPENDS = "ffmpeg gstreamer gst-plugins-base zlib"
+PR = "r1"
+
inherit autotools pkgconfig
SRC_URI = "http://gstreamer.freedesktop.org/src/${PN}/${PN}-${PV}.tar.bz2 \
@@ -23,7 +25,3 @@ EXTRA_OECONF = " --with-system-ffmpeg "
# We do this because the install program is called with -s which causes it to
# call "strip" and it then mangles cross compiled stuff..
PATH_prepend := "${TOOLCHAIN_PATH}/${TARGET_SYS}/bin:"
-
-# Hack to get STAGING_LIBDIR into the linker path when building ffmpeg
-CC = "${CCACHE} ${HOST_PREFIX}gcc ${TARGET_CC_ARCH} -L${STAGING_LIBDIR}"
-