aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gtk+/gtk+_2.14.2.bb
diff options
context:
space:
mode:
authorFlorian Boor <florian.boor@kernelconcepts.de>2009-05-08 11:52:14 +0200
committerFlorian Boor <florian.boor@kernelconcepts.de>2009-05-08 12:14:34 +0200
commit35f4afb025e5f6c0b5e883c2993b50103e9a2d64 (patch)
tree734f7034954cea62a48bf2270a7f1f04a0a0e911 /recipes/gtk+/gtk+_2.14.2.bb
parent491b936c67225ef311a58b799c9e4280fe523fec (diff)
downloadopenembedded-35f4afb025e5f6c0b5e883c2993b50103e9a2d64.tar.gz
gtk+: Fix preferred 2.14.2 like 2.16.0: stage gtk-builder-convert
Diffstat (limited to 'recipes/gtk+/gtk+_2.14.2.bb')
-rw-r--r--recipes/gtk+/gtk+_2.14.2.bb12
1 files changed, 11 insertions, 1 deletions
diff --git a/recipes/gtk+/gtk+_2.14.2.bb b/recipes/gtk+/gtk+_2.14.2.bb
index eb6cc536b9..0289e2ed22 100644
--- a/recipes/gtk+/gtk+_2.14.2.bb
+++ b/recipes/gtk+/gtk+_2.14.2.bb
@@ -1,6 +1,6 @@
require gtk+.inc
-PR = "r4"
+PR = "r5"
DEPENDS += "cairo jasper"
@@ -39,6 +39,16 @@ python populate_packages_prepend () {
bb.data.setVar('PKG_${PN}', 'libgtk-2.0', d)
}
+
+do_stage_append() {
+
+ # this tool is required by gnome-keyring 2.26.0 to get built
+ # it is written in Python and use only Python xml
+ install -d ${STAGING_BINDIR_NATIVE}
+ install -m 0755 ${S}/gtk/gtk-builder-convert ${STAGING_BINDIR_NATIVE}
+
+}
+
# gail is part of gtk+ since gtk+-2.13.0 (targetting >=GNOME 2.23):
PROVIDES = "virtual/gail"
RPROVIDES_${PN} = "libgailutil18"