aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gtk+/gtk+_2.18.6.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-01-31 17:14:17 +0100
committerKoen Kooi <koen@openembedded.org>2010-01-31 17:16:28 +0100
commit741a2834cb11bb498aef4522e1857a35e14c8da6 (patch)
treeb876770015f72fb64c024f8a949b94eb0a29d876 /recipes/gtk+/gtk+_2.18.6.bb
parentc6d759bc19db2f2027309137f67b2618fcfdb564 (diff)
downloadopenembedded-741a2834cb11bb498aef4522e1857a35e14c8da6.tar.gz
gtk+: don't install the pixbug-csource tool when building -native, it doesn't work properly
* the work around involved cleaning up old recipes as well, new-style staging here we come!
Diffstat (limited to 'recipes/gtk+/gtk+_2.18.6.bb')
-rw-r--r--recipes/gtk+/gtk+_2.18.6.bb14
1 files changed, 13 insertions, 1 deletions
diff --git a/recipes/gtk+/gtk+_2.18.6.bb b/recipes/gtk+/gtk+_2.18.6.bb
index 6476f4c003..674a88a731 100644
--- a/recipes/gtk+/gtk+_2.18.6.bb
+++ b/recipes/gtk+/gtk+_2.18.6.bb
@@ -1,12 +1,24 @@
require gtk+.inc
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
+
+BBCLASSEXTEND = "native"
+
+DEPENDS_virtclass-native = "atk-native pango-native cairo-native"
# Enable xkb selectively
XKBTOGGLE = " --disable-xkb"
XKBTOGGLE_angstrom = ""
EXTRA_OECONF = "--with-libtiff ${XKBTOGGLE} --disable-glibtest gio_can_sniff=yes"
+EXTRA_OECONF_append_virtclass-native = " --without-libtiff --disable-modules"
+
+do_install_virtclass-native () {
+ autotools_do_install
+ find ${D}${libdir} -name "libpixbufloader-*.la" -exec rm \{\} \;
+ rm ${D}${bindir}/gdk-pixbuf-csource
+ echo "going native!"
+}
PACKAGES_DYNAMIC = "gtk-module-* gdk-pixbuf-loader-* gtk-immodule-* gtk-printbackend-*"