aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gtk+
diff options
context:
space:
mode:
authorAndreas Oberritter <obi@opendreambox.org>2010-11-21 22:34:23 +0000
committerYuri Bushmelev <jay4mail@gmail.com>2010-11-23 02:26:11 +0300
commit9fe39e4a31892414682bbce967098159cfd06547 (patch)
tree43821b36ba703d4c9afe0324f23f00392add94ac /recipes/gtk+
parentd28cdb2d2e6c910afbaa14b17bd2c0003052df7d (diff)
downloadopenembedded-9fe39e4a31892414682bbce967098159cfd06547.tar.gz
gtk+-1.2: convert to new style staging (fixes xmms build)
* gtk+-1.2 didn't install its pkg-config file, but gtk-config depended on it and went crazy without it. xmms uses gtk-config. Signed-off-by: Andreas Oberritter <obi@opendreambox.org> Tested-by: Yury Bushmelev <jay4mail@gmail.com> Tested-by: Philip Balister <philip@balister.org> Tested-by: Paul Menzel <paulepanter@users.sourceforge.net> Acked-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/gtk+')
-rw-r--r--recipes/gtk+/gtk+-1.2_1.2.10.bb30
1 files changed, 2 insertions, 28 deletions
diff --git a/recipes/gtk+/gtk+-1.2_1.2.10.bb b/recipes/gtk+/gtk+-1.2_1.2.10.bb
index 2e5f86d0bb..a503eabbf2 100644
--- a/recipes/gtk+/gtk+-1.2_1.2.10.bb
+++ b/recipes/gtk+/gtk+-1.2_1.2.10.bb
@@ -4,7 +4,7 @@ HOMEPAGE = "http://www.gtk.org"
SECTION = "libs"
PRIORITY = "optional"
DEPENDS = "glib-1.2 jpeg libpng libxext"
-PR = "r3"
+PR = "r4"
SRC_URI = "ftp://ftp.gtk.org/pub/gtk/v1.2/gtk+-${PV}.tar.gz \
file://timezone-fix.patch \
@@ -15,7 +15,7 @@ SRC_URI_append_jlime = " file://small-filesel.patch "
S = "${WORKDIR}/gtk+-${PV}"
-inherit autotools pkgconfig flow-lossage
+inherit autotools pkgconfig flow-lossage binconfig
do_configure_prepend() {
install -d m4
@@ -28,32 +28,6 @@ FILES_${PN}-dev += "${datadir}/gtk-1.2/include ${libdir}/gtk-1.2/include"
EXTRA_OECONF = "--enable-debug=no --disable-glibtest --disable-xim"
-# --disable-cruft
-
-LIBV = "1.2.10"
-
-gtk_include = "fnmatch.h gtk.h gtkaccelgroup.h gtkaccellabel.h gtkadjustment.h gtkalignment.h gtkarg.h gtkarrow.h gtkaspectframe.h gtkbbox.h gtkbin.h gtkbindings.h gtkbox.h gtkbutton.h gtkcalendar.h gtkcheckbutton.h gtkcheckmenuitem.h gtkclist.h gtkcolorsel.h gtkcombo.h gtkcompat.h gtkcontainer.h gtkctree.h gtkcurve.h gtkdata.h gtkdebug.h gtkdialog.h gtkdnd.h gtkdrawingarea.h gtkeditable.h gtkentry.h gtkenums.h gtkeventbox.h gtkfeatures.h gtkfilesel.h gtkfixed.h gtkfontsel.h gtkframe.h gtkgamma.h gtkgc.h gtkhandlebox.h gtkhbbox.h gtkhbox.h gtkhpaned.h gtkhruler.h gtkhscale.h gtkhscrollbar.h gtkhseparator.h gtkimage.h gtkinputdialog.h gtkintl.h gtkinvisible.h gtkitem.h gtkitemfactory.h gtklabel.h gtklayout.h gtklist.h gtklistitem.h gtkmain.h gtkmarshal.h gtkmenu.h gtkmenubar.h gtkmenufactory.h gtkmenuitem.h gtkmenushell.h gtkmisc.h gtknotebook.h gtkobject.h gtkoptionmenu.h gtkpacker.h gtkpaned.h gtkpixmap.h gtkplug.h gtkpreview.h gtkprivate.h gtkprogress.h gtkprogressbar.h gtkradiobutton.h gtkradiomenuitem.h gtkrange.h gtkrc.h gtkruler.h gtkscale.h gtkscrollbar.h gtkscrolledwindow.h gtkselection.h gtkseparator.h gtksignal.h gtksocket.h gtkspinbutton.h gtkstatusbar.h gtkstyle.h gtktable.h gtktearoffmenuitem.h gtktext.h gtkthemes.h gtktipsquery.h gtktogglebutton.h gtktoolbar.h gtktooltips.h gtktree.h gtktreeitem.h gtktypebuiltins.h gtktypeutils.h gtkvbbox.h gtkvbox.h gtkviewport.h gtkvpaned.h gtkvruler.h gtkvscale.h gtkvscrollbar.h gtkvseparator.h gtkwidget.h gtkwindow.h makeenums.h stamp-gtkmarshal.h stamp-gtktypebuiltins.h"
-gdk_include = "MwmUtil.h gdk.h gdkcursors.h gdki18n.h gdkinput.h gdkinputcommon.h gdkinputgxi.h gdkinputnone.h gdkinputxfree.h gdkkeysyms.h gdkprivate.h gdkrgb.h gdktypes.h gdkx.h gxid_lib.h gxid_proto.h"
-
-do_stage () {
- oe_libinstall -so -C gtk libgtk ${STAGING_LIBDIR}
- oe_libinstall -so -C gdk libgdk ${STAGING_LIBDIR}
-
- mkdir -p ${STAGING_INCDIR}/gtk-1.2/gtk
- for i in ${gtk_include}; do
- install -m 0644 gtk/$i ${STAGING_INCDIR}/gtk-1.2/gtk/$i
- done
-
- mkdir -p ${STAGING_INCDIR}/gtk-1.2/gdk
- for i in ${gdk_include}; do
- install -m 0644 gdk/$i ${STAGING_INCDIR}/gtk-1.2/gdk/$i
- done
-
- mkdir -p ${STAGING_LIBDIR}/gtk-1.2/include
-
- install -m 0644 gtk.m4 ${STAGING_DATADIR}/aclocal/
- install -m 0755 gtk-config ${STAGING_BINDIR_CROSS}/
-}
do_install_append () {
install -d ${D}${sysconfdir}/gtk-1.2