aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gtk+
diff options
context:
space:
mode:
authorPhil Blundell <philb@gnu.org>2010-03-09 20:38:16 +0000
committerPhil Blundell <philb@gnu.org>2010-03-09 20:38:16 +0000
commit0135ae31d148e2175a0d7d9a92180d70b4a8e0b5 (patch)
treef24197dfc809800b4720d0a0a9bed305be581aea /recipes/gtk+
parent6be933980ea93350556e8f06c42493a9f7ce76af (diff)
downloadopenembedded-0135ae31d148e2175a0d7d9a92180d70b4a8e0b5.tar.gz
gtk+: remove special-casing for native installation, declare provider for gdk-pixbuf-csource-native when building natively
(based on original patch from Graeme Gregory <dp@xora.org.uk> with minor edits)
Diffstat (limited to 'recipes/gtk+')
-rw-r--r--recipes/gtk+/gtk+.inc2
-rw-r--r--recipes/gtk+/gtk+_2.18.6.bb10
2 files changed, 3 insertions, 9 deletions
diff --git a/recipes/gtk+/gtk+.inc b/recipes/gtk+/gtk+.inc
index e6a0684fcc..268657be0e 100644
--- a/recipes/gtk+/gtk+.inc
+++ b/recipes/gtk+/gtk+.inc
@@ -5,7 +5,7 @@ SECTION = "libs"
LICENSE = "LGPL"
PRIORITY = "optional"
DEPENDS = "glib-2.0 tiff pango atk jpeg libpng libxext libxcursor gtk-doc libgcrypt cups \
- libxrandr libxdamage libxrender libxcomposite cairo jasper"
+ libxrandr libxdamage libxrender libxcomposite cairo jasper gtk+-native"
PROVIDES = "gdk-pixbuf"
MAJ_VER = "${@bb.data.getVar('PV',d,1).split('.')[0]}.${@bb.data.getVar('PV',d,1).split('.')[1]}"
diff --git a/recipes/gtk+/gtk+_2.18.6.bb b/recipes/gtk+/gtk+_2.18.6.bb
index 9321b43dfa..8546591187 100644
--- a/recipes/gtk+/gtk+_2.18.6.bb
+++ b/recipes/gtk+/gtk+_2.18.6.bb
@@ -8,20 +8,14 @@ PR = "${INC_PR}.3"
BBCLASSEXTEND = "native"
DEPENDS_virtclass-native = "libpng-native atk-native pango-native cairo-native libxrender-native"
+PROVIDES_virtclass-native = "gdk-pixbuf-csource-native"
# Enable xkb selectively
XKBTOGGLE = " --disable-xkb"
XKBTOGGLE_angstrom = ""
EXTRA_OECONF = "--with-libtiff ${XKBTOGGLE} --disable-glibtest gio_can_sniff=yes"
-EXTRA_OECONF_append_virtclass-native = " --without-libtiff --without-libjpeg --disable-modules"
-
-do_install_virtclass-native () {
- autotools_do_install
- find ${D}${libdir} -name "libpixbufloader-*.la" -exec rm \{\} \;
- rm ${D}${bindir}/gdk-pixbuf-csource
- echo "going native!"
-}
+EXTRA_OECONF_append_virtclass-native = " --without-libtiff --without-libjpeg"
PACKAGES_DYNAMIC = "gtk-module-* gdk-pixbuf-loader-* gtk-immodule-* gtk-printbackend-*"