aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gtk+
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <marcin@juszkiewicz.com.pl>2009-03-30 14:28:23 +0200
committerMarcin Juszkiewicz <hrw@openembedded.org>2009-03-30 15:23:58 +0200
commit49905a2449aad3d729fa383fff4fc694e5dc35ee (patch)
treedaec0be003b37f6226befb05f898fd039b252bc5 /recipes/gtk+
parent27759557d31bc9fea07f5b34cb59743e1f95aabc (diff)
downloadopenembedded-49905a2449aad3d729fa383fff4fc694e5dc35ee.tar.gz
gtk+: stage gtk-builder-convert to get gnome-keyring built
Diffstat (limited to 'recipes/gtk+')
-rw-r--r--recipes/gtk+/gtk+_2.16.0.bb9
1 files changed, 9 insertions, 0 deletions
diff --git a/recipes/gtk+/gtk+_2.16.0.bb b/recipes/gtk+/gtk+_2.16.0.bb
index 7841354727..c6505effef 100644
--- a/recipes/gtk+/gtk+_2.16.0.bb
+++ b/recipes/gtk+/gtk+_2.16.0.bb
@@ -1,6 +1,7 @@
require gtk+.inc
DEPENDS += "cairo jasper"
+PR = "r1"
# disabled per default - this uses as little patches as possible
DEFAULT_PREFERENCE = "-1"
@@ -43,3 +44,11 @@ RPROVIDES_${PN} = "libgailutil18"
RCONFLICTS_${PN} = "libgailutil18"
RREPLACES_${PN} = "libgailutil18"
+do_stage_append() {
+
+ # this tool is required by gnome-keyring 2.26.0 to get built
+ # it is written in Python and use only Python xml
+ install -d ${STAGING_BINDIR_NATIVE}
+ install -m 0755 ${S}/gtk/gtk-builder-convert ${STAGING_BINDIR_NATIVE}
+
+}