aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gtk-engines
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-04-08 14:32:32 +0200
committerKoen Kooi <koen@openembedded.org>2010-04-08 14:32:32 +0200
commitdf9cefd2955f3c1d26f4f6830f9a0e17dc7fb629 (patch)
treefda78ac56d1cb5b42be719ba2b4b4f161b036f0c /recipes/gtk-engines
parent9e1803c61bba6235a987c3e5a2d1e7da28ee1d8d (diff)
downloadopenembedded-df9cefd2955f3c1d26f4f6830f9a0e17dc7fb629.tar.gz
elementary-icon-theme: add 2.2 from openpandora OE overlay
Diffstat (limited to 'recipes/gtk-engines')
-rw-r--r--recipes/gtk-engines/elementary-icon-theme-enable.bb14
-rw-r--r--recipes/gtk-engines/elementary-icon-theme_2.2.bb28
2 files changed, 42 insertions, 0 deletions
diff --git a/recipes/gtk-engines/elementary-icon-theme-enable.bb b/recipes/gtk-engines/elementary-icon-theme-enable.bb
new file mode 100644
index 0000000000..abe6afdf19
--- /dev/null
+++ b/recipes/gtk-engines/elementary-icon-theme-enable.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "Enable elementary-icon-theme in gtkrc"
+
+RDEPENDS_${PN} = "elementary-icon-theme"
+
+ALLOW_EMPTY_${PN} = "1"
+PACKAGE_ARCH = "all"
+
+pkg_postinst() {
+#!/bin/sh
+mkdir -p $D${sysconfdir}/gtk-2.0
+touch $D${sysconfdir}/gtk-2.0/gtkrc
+sed -i /gtk-icon-theme-name/d $D${sysconfdir}/gtk-2.0/gtkrc
+echo 'gtk-icon-theme-name = "elementary"' >> $D${sysconfdir}/gtk-2.0/gtkrc
+}
diff --git a/recipes/gtk-engines/elementary-icon-theme_2.2.bb b/recipes/gtk-engines/elementary-icon-theme_2.2.bb
new file mode 100644
index 0000000000..794d1dcc23
--- /dev/null
+++ b/recipes/gtk-engines/elementary-icon-theme_2.2.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "Icon theme from the Elementary project"
+SECTION = "x11/icons"
+HOMEPAGE = "http://www.elementary-project.com/"
+
+inherit gtk-icon-cache
+
+# We have to get the icons from a mirror (LaunchPad) as DeviantArt has a download
+# wrapper to stop simple HTTP gets :(.
+
+SRC_URI = " \
+ http://launchpad.net/elementaryicons/2.0/2.2/+download/elementary_2.2.tar.gz;name=archive \
+"
+
+SRC_URI[archive.md5sum] = "fb740a046d8d728613499a77b77bc1e2"
+SRC_URI[archive.sha256sum] = "49672fc965b30cc6c5c2589a1b72c5187a2d185e7f6d599968172fd694f28ea6"
+
+S = "${WORKDIR}/elementary_2.2"
+
+do_install() {
+ install -d ${D}${datadir}/icons/
+ install -d ${D}${datadir}/icons/elementary/
+ cp -r ${S}/* "${D}${datadir}/icons/elementary/"
+}
+
+FILES_${PN} = "${datadir}/icons/elementary/"
+RDEPENDS_${PN} += "gnome-icon-theme"
+PACKAGE_ARCH = "all"
+