aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gtk-engines
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-04-08 14:23:46 +0200
committerKoen Kooi <koen@openembedded.org>2010-04-08 14:23:46 +0200
commitd60ef74778629762534940aa82e2b44aa77eb7fe (patch)
tree23cae0e93a368cdcfaea277c4e1a979fc1084d84 /recipes/gtk-engines
parentaf23f72bc8987bf3533d1001c38f8f2ffb910900 (diff)
downloadopenembedded-d60ef74778629762534940aa82e2b44aa77eb7fe.tar.gz
gtk-engines: add 2.20.0
Diffstat (limited to 'recipes/gtk-engines')
-rw-r--r--recipes/gtk-engines/gtk-engines_2.20.0.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/recipes/gtk-engines/gtk-engines_2.20.0.bb b/recipes/gtk-engines/gtk-engines_2.20.0.bb
new file mode 100644
index 0000000000..5424ce5e91
--- /dev/null
+++ b/recipes/gtk-engines/gtk-engines_2.20.0.bb
@@ -0,0 +1,35 @@
+LICENSE = "GPL"
+SECTION = "x11/base"
+DESCRIPTION = "GTK theme engines"
+DEPENDS = "gtk+ cairo"
+
+inherit gnome gtk-binver
+
+SRC_URI[archive.md5sum] = "c55d7932ba2ebfeedfb19cd4652b5c75"
+SRC_URI[archive.sha256sum] = "69b2e6798cfdcf7366b025b8f59fc63f658474f823d185473e94f969bae8cad1"
+
+PACKAGES_DYNAMIC = "gtk-engine-* gtk-theme-*"
+
+RDEPENDS_gtk-theme-redmond = "gtk-engine-redmond95"
+RDEPENDS_gtk-theme-metal = "gtk-engine-metal"
+RDEPENDS_gtk-theme-mist = "gtk-engine-mist"
+RDEPENDS_gtk-theme-crux = "gtk-engine-crux-engine"
+RDEPENDS_gtk-theme-lighthouseblue = "gtk-engine-lighthouseblue"
+RDEPENDS_gtk-theme-thinice = "gtk-engine-thinice"
+RDEPENDS_gtk-theme-industrial = "gtk-engine-industrial"
+RDEPENDS_gtk-theme-clearlooks = "gtk-engine-clearlooks"
+
+RREPLACES_gtk-theme-clearlooks = "gpe-theme-clearlooks"
+
+python populate_packages_prepend() {
+ import os.path
+
+ engines_ver = ['gtk-2.0/', gtkbinver_find(d), '/engines']
+
+ engines_root = os.path.join(bb.data.getVar('libdir', d, 1), ''.join(engines_ver))
+ themes_root = os.path.join(bb.data.getVar('datadir', d, 1), "themes")
+
+ do_split_packages(d, engines_root, '^lib(.*)\.so$', 'gtk-engine-%s', 'GTK %s theme engine', extra_depends='')
+ do_split_packages(d, themes_root, '(.*)', 'gtk-theme-%s', 'GTK theme %s', allow_dirs=True, extra_depends='')
+}
+