summaryrefslogtreecommitdiffstats
path: root/recipes/gtk-engines
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2009-04-16 19:41:31 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2009-05-20 23:15:13 -0300
commit1232133c9cf1aa893edd37cfaf4a0f299ecb052a (patch)
tree6667baffb8aae157f063ffffbe351b7822ff114c /recipes/gtk-engines
parent4e16e013376f03545991fb052aa0c09c9a15cd52 (diff)
downloadopenembedded-1232133c9cf1aa893edd37cfaf4a0f299ecb052a.tar.gz
gtk-engines: add 2.18.1
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes/gtk-engines')
-rw-r--r--recipes/gtk-engines/gtk-engines_2.18.1.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes/gtk-engines/gtk-engines_2.18.1.bb b/recipes/gtk-engines/gtk-engines_2.18.1.bb
new file mode 100644
index 0000000000..177c5b8baf
--- /dev/null
+++ b/recipes/gtk-engines/gtk-engines_2.18.1.bb
@@ -0,0 +1,30 @@
+LICENSE = "GPL"
+SECTION = "x11/base"
+DESCRIPTION = "GTK theme engines"
+DEPENDS = "gtk+ cairo"
+
+RDEPENDS_gtk-theme-redmond = "gtk-engine-redmond95"
+RDEPENDS_gtk-theme-metal = "gtk-engine-metal"
+RDEPENDS_gtk-theme-mist = "gtk-engine-mist"
+RDEPENDS_gtk-theme-crux = "gtk-engine-crux-engine"
+RDEPENDS_gtk-theme-lighthouseblue = "gtk-engine-lighthouseblue"
+RDEPENDS_gtk-theme-thinice = "gtk-engine-thinice"
+RDEPENDS_gtk-theme-industrial = "gtk-engine-industrial"
+RDEPENDS_gtk-theme-clearlooks = "gtk-engine-clearlooks"
+
+inherit gnome gtk-binver
+
+PACKAGES_DYNAMIC = "gtk-engine-* gtk-theme-*"
+
+python populate_packages_prepend() {
+ import os.path
+
+ engines_ver = ['gtk-2.0/', gtkbinver_find(d), '/engines']
+
+ engines_root = os.path.join(bb.data.getVar('libdir', d, 1), ''.join(engines_ver))
+ themes_root = os.path.join(bb.data.getVar('datadir', d, 1), "themes")
+
+ do_split_packages(d, engines_root, '^lib(.*)\.so$', 'gtk-engine-%s', 'GTK %s theme engine', extra_depends='')
+ do_split_packages(d, themes_root, '(.*)', 'gtk-theme-%s', 'GTK theme %s', allow_dirs=True, extra_depends='')
+}
+