summaryrefslogtreecommitdiffstats
path: root/recipes/gtk-webcore/midori_0.1.5.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-03-28 20:44:11 +0100
committerKoen Kooi <koen@openembedded.org>2009-03-28 20:44:11 +0100
commitecf551ef71b1470104996d1813302b61b77dd402 (patch)
treeeae58100413cbcd68c006ad4eb6f169ea2881c03 /recipes/gtk-webcore/midori_0.1.5.bb
parent308bbb0a550a70439701834dae44447f24383fa7 (diff)
downloadopenembedded-ecf551ef71b1470104996d1813302b61b77dd402.tar.gz
midori: update to 0.1.5 and workaround an issue with the abomination called 'waf'
* runtime tested on beagleboard
Diffstat (limited to 'recipes/gtk-webcore/midori_0.1.5.bb')
-rw-r--r--recipes/gtk-webcore/midori_0.1.5.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes/gtk-webcore/midori_0.1.5.bb b/recipes/gtk-webcore/midori_0.1.5.bb
new file mode 100644
index 0000000000..c1d1f66fe7
--- /dev/null
+++ b/recipes/gtk-webcore/midori_0.1.5.bb
@@ -0,0 +1,31 @@
+require midori.inc
+
+DEPENDS += "python-native python-docutils-native"
+
+SRC_URI = "http://goodies.xfce.org/releases/midori/midori-${PV}.tar.bz2 \
+ file://waf"
+
+
+do_configure() {
+ cp -f ${WORKDIR}/waf ${S}/
+ ./configure \
+ --prefix=${prefix} \
+ --bindir=${bindir} \
+ --sbindir=${sbindir} \
+ --libexecdir=${libexecdir} \
+ --datadir=${datadir} \
+ --sysconfdir=${sysconfdir} \
+ --sharedstatedir=${sharedstatedir} \
+ --localstatedir=${localstatedir} \
+ --libdir=${libdir} \
+ --includedir=${includedir} \
+ --infodir=${infodir} \
+ --mandir=${mandir} \
+ ${EXTRA_OECONF}
+
+ sed -i /LINK_CC/d ./_build_/c4che/default.cache.py
+ echo "LINK_CC = '${CXX}'" >> ./_build_/c4che/default.cache.py
+}
+
+
+