aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gtk-webcore/osb-jscore-0.5.0
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/gtk-webcore/osb-jscore-0.5.0
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/gtk-webcore/osb-jscore-0.5.0')
-rw-r--r--recipes/gtk-webcore/osb-jscore-0.5.0/gcc4-fno-threadsafe-statics.patch11
-rw-r--r--recipes/gtk-webcore/osb-jscore-0.5.0/libm.patch13
-rw-r--r--recipes/gtk-webcore/osb-jscore-0.5.0/missing-includes.patch10
-rw-r--r--recipes/gtk-webcore/osb-jscore-0.5.0/superh-aclocal.patch11
-rw-r--r--recipes/gtk-webcore/osb-jscore-0.5.0/superh-ustring-declaration-error.patch47
5 files changed, 92 insertions, 0 deletions
diff --git a/recipes/gtk-webcore/osb-jscore-0.5.0/gcc4-fno-threadsafe-statics.patch b/recipes/gtk-webcore/osb-jscore-0.5.0/gcc4-fno-threadsafe-statics.patch
new file mode 100644
index 0000000000..44e69b2707
--- /dev/null
+++ b/recipes/gtk-webcore/osb-jscore-0.5.0/gcc4-fno-threadsafe-statics.patch
@@ -0,0 +1,11 @@
+--- osb-jscore-0.5.0/configure.in_orig 2006-09-18 00:37:27.000000000 +0000
++++ osb-jscore-0.5.0/configure.in 2006-09-18 00:37:51.000000000 +0000
+@@ -61,7 +61,7 @@
+ fi
+ changequote([,])dnl
+
+-CXXFLAGS="$CXXFLAGS -fno-exceptions -fno-rtti -nostdinc++"
++CXXFLAGS="$CXXFLAGS -fno-exceptions -fno-rtti -nostdinc++ -fno-threadsafe-statics"
+ LDFLAGS="$LDFLAGS -nodefaultlibs -lgcc -lc -lm"
+
+ CPPFLAGS="$CPPFLAGS -I\$(top_srcdir)/kjs -I\$(top_srcdir)/pcre -I\$(top_srcdir)/"
diff --git a/recipes/gtk-webcore/osb-jscore-0.5.0/libm.patch b/recipes/gtk-webcore/osb-jscore-0.5.0/libm.patch
new file mode 100644
index 0000000000..b0c0cc6af2
--- /dev/null
+++ b/recipes/gtk-webcore/osb-jscore-0.5.0/libm.patch
@@ -0,0 +1,13 @@
+Index: osb-jscore-0.5.0/configure.in
+===================================================================
+--- osb-jscore-0.5.0.orig/configure.in 2004-10-18 11:39:43.000000000 -0400
++++ osb-jscore-0.5.0/configure.in 2005-02-02 17:36:36.551550088 -0500
+@@ -18,6 +18,8 @@
+ AC_CHECK_HEADERS(string.h strings.h float.h)
+
+
++# isnan & friends generally come from libm, so link to it if its available
++AC_CHECK_LIB(m, sin)
+
+ AC_CHECK_FUNCS(isnan,[
+ AC_DEFINE(HAVE_FUNC_ISNAN,[],[Define to 1 if you have isnan function.])
diff --git a/recipes/gtk-webcore/osb-jscore-0.5.0/missing-includes.patch b/recipes/gtk-webcore/osb-jscore-0.5.0/missing-includes.patch
new file mode 100644
index 0000000000..42d6ebc9f8
--- /dev/null
+++ b/recipes/gtk-webcore/osb-jscore-0.5.0/missing-includes.patch
@@ -0,0 +1,10 @@
+--- osb-jscore-0.5.0.orig/kjs/lookup.h 2004-09-23 10:27:54.000000000 +0200
++++ osb-jscore-0.5.0/kjs/lookup.h 2004-10-23 22:09:47.000000000 +0200
+@@ -24,6 +24,7 @@
+ #define _KJSLOOKUP_H_
+
+ #include "identifier.h"
++#include "object.h"
+ #include "value.h"
+ #include <stdio.h>
+
diff --git a/recipes/gtk-webcore/osb-jscore-0.5.0/superh-aclocal.patch b/recipes/gtk-webcore/osb-jscore-0.5.0/superh-aclocal.patch
new file mode 100644
index 0000000000..706dead8c3
--- /dev/null
+++ b/recipes/gtk-webcore/osb-jscore-0.5.0/superh-aclocal.patch
@@ -0,0 +1,11 @@
+--- osb-jscore-0.5.0/aclocal.m4_orig 2006-09-18 00:49:32.000000000 +0000
++++ osb-jscore-0.5.0/aclocal.m4 2006-09-18 00:49:52.000000000 +0000
+@@ -4299,7 +4299,7 @@
+ # This must be Linux ELF.
+ linux-gnu*)
+ case $host_cpu in
+- alpha* | hppa* | i*86 | mips | mipsel | powerpc* | sparc* | ia64* | s390* | x86_64*)
++ alpha* | hppa* | i*86 | mips | mipsel | powerpc* | sparc* | ia64* | s390* | sh* | x86_64*)
+ lt_cv_deplibs_check_method=pass_all ;;
+ *)
+ # glibc up to 2.1.1 does not perform some relocations on ARM
diff --git a/recipes/gtk-webcore/osb-jscore-0.5.0/superh-ustring-declaration-error.patch b/recipes/gtk-webcore/osb-jscore-0.5.0/superh-ustring-declaration-error.patch
new file mode 100644
index 0000000000..c0c52444c8
--- /dev/null
+++ b/recipes/gtk-webcore/osb-jscore-0.5.0/superh-ustring-declaration-error.patch
@@ -0,0 +1,47 @@
+--- osb-jscore-0.5.0/kjs/ustring.cpp_orig 2006-09-18 01:29:11.000000000 +0000
++++ osb-jscore-0.5.0/kjs/ustring.cpp 2006-09-18 01:29:46.000000000 +0000
+@@ -132,7 +132,7 @@
+ return *this;
+ }
+
+-bool KJS::operator==(const KJS::CString& c1, const KJS::CString& c2)
++bool operator==(const KJS::CString& c1, const KJS::CString& c2)
+ {
+ int len = c1.size();
+ return len == c2.size() && (len == 0 || memcmp(c1.c_str(), c2.c_str(), len) == 0);
+@@ -1094,7 +1094,7 @@
+ rep->deref();
+ }
+
+-bool KJS::operator==(const UString& s1, const UString& s2)
++bool operator==(const UString& s1, const UString& s2)
+ {
+ if (s1.rep->len != s2.rep->len)
+ return false;
+@@ -1103,7 +1103,7 @@
+ s1.rep->len * sizeof(UChar)) == 0);
+ }
+
+-bool KJS::operator==(const UString& s1, const char *s2)
++bool operator==(const UString& s1, const char *s2)
+ {
+ if (s2 == 0) {
+ return s1.isEmpty();
+@@ -1121,7 +1121,7 @@
+ return u == uend && *s2 == 0;
+ }
+
+-bool KJS::operator<(const UString& s1, const UString& s2)
++bool operator<(const UString& s1, const UString& s2)
+ {
+ const int l1 = s1.size();
+ const int l2 = s2.size();
+@@ -1140,7 +1140,7 @@
+ return (l1 < l2);
+ }
+
+-int KJS::compare(const UString& s1, const UString& s2)
++int compare(const UString& s1, const UString& s2)
+ {
+ const int l1 = s1.size();
+ const int l2 = s2.size();