aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gtk-webcore
diff options
context:
space:
mode:
authorUlf Samuelsson <ulf.samuelsson@atmel.com>2010-03-16 08:10:31 +0100
committerUlf Samuelsson <ulf.samuelsson@atmel.com>2010-03-16 08:10:31 +0100
commit9f06d76aaebf119e56973a0a2eecfa17689e3b0c (patch)
tree7b52a7e889ce7a0ae490744ce310b8adf7e5b7a4 /recipes/gtk-webcore
parentede720badf45fe73a900013967dd622e1add201a (diff)
downloadopenembedded-9f06d76aaebf119e56973a0a2eecfa17689e3b0c.tar.gz
osb-jscore_svn.bb: Templates cannot be static
"static inline" templates in "JavaScriptCore/kjs/protected_values.cpp" causes compile errors This patch removes the static keywords allowing the build to complete successfully. Signed-off-by: Ulf Samuelsson <ulf.samuelsson@atmel.com>
Diffstat (limited to 'recipes/gtk-webcore')
-rw-r--r--recipes/gtk-webcore/files/no-static-templates.patch21
-rw-r--r--recipes/gtk-webcore/osb-jscore_svn.bb6
2 files changed, 25 insertions, 2 deletions
diff --git a/recipes/gtk-webcore/files/no-static-templates.patch b/recipes/gtk-webcore/files/no-static-templates.patch
new file mode 100644
index 0000000000..2cfb41f655
--- /dev/null
+++ b/recipes/gtk-webcore/files/no-static-templates.patch
@@ -0,0 +1,21 @@
+diff -urN JavaScriptCore-0rig/kjs/protected_values.cpp JavaScriptCore/kjs/protected_values.cpp
+--- JavaScriptCore-0rig/kjs/protected_values.cpp 2010-02-26 12:57:50.000000000 +0100
++++ JavaScriptCore/kjs/protected_values.cpp 2010-02-26 12:59:13.000000000 +0100
+@@ -195,7 +195,7 @@
+
+ template <int size> static unsigned hash(ValueImp *pointer);
+
+-template <> static inline unsigned hash<4>(ValueImp *pointer)
++template <> inline unsigned hash<4>(ValueImp *pointer)
+ {
+ int a = (int)(intptr_t)PHI;
+ int b = (int)(intptr_t)pointer;
+@@ -214,7 +214,7 @@
+ return (unsigned)c;
+ }
+
+-template <> static inline unsigned hash<8>(ValueImp *pointer)
++template <> inline unsigned hash<8>(ValueImp *pointer)
+ {
+ int a = (int)PHI;
+ int b = (int)(intptr_t)pointer;
diff --git a/recipes/gtk-webcore/osb-jscore_svn.bb b/recipes/gtk-webcore/osb-jscore_svn.bb
index 52c56f98b5..af85764842 100644
--- a/recipes/gtk-webcore/osb-jscore_svn.bb
+++ b/recipes/gtk-webcore/osb-jscore_svn.bb
@@ -4,10 +4,12 @@ LICENSE = "GPL"
PRIORITY = "optional"
PV = "0.5.2+svnr${SRCPV}"
-PR = "r1"
+PR = "r2"
SRC_URI = "svn://gtk-webcore.svn.sourceforge.net/svnroot/gtk-webcore/trunk;module=JavaScriptCore;proto=https \
- file://gcc4-fno-threadsafe-statics-JavaScriptCore.patch;patch=1"
+ file://gcc4-fno-threadsafe-statics-JavaScriptCore.patch;patch=1 \
+ file://no-static-templates.patch;patch=1 \
+ "
S = "${WORKDIR}/JavaScriptCore"