summaryrefslogtreecommitdiffstats
path: root/recipes/guichan
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/guichan
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/guichan')
-rw-r--r--recipes/guichan/files/link-against-sdlimage.patch22
-rw-r--r--recipes/guichan/guichan_0.7.1.bb22
2 files changed, 44 insertions, 0 deletions
diff --git a/recipes/guichan/files/link-against-sdlimage.patch b/recipes/guichan/files/link-against-sdlimage.patch
new file mode 100644
index 0000000000..e2e3ddb2e6
--- /dev/null
+++ b/recipes/guichan/files/link-against-sdlimage.patch
@@ -0,0 +1,22 @@
+Index: guichan-0.6.1/configure.in
+===================================================================
+--- guichan-0.6.1.orig/configure.in 2007-09-28 18:35:17.000000000 +0200
++++ guichan-0.6.1/configure.in 2007-09-28 18:36:10.000000000 +0200
+@@ -116,6 +116,7 @@
+ SDLIMAGE="yes"
+ SDL_LIBS="$SDL_LIBS -lSDL_image"
+ CPPFLAGS="$CPPFLAGS `sdl-config --cflags`"
++ AC_SUBST([SDL_LIBS])
+ }
+
+ ForceSDLImage()
+Index: guichan-0.6.1/src/sdl/Makefile.am
+===================================================================
+--- guichan-0.6.1.orig/src/sdl/Makefile.am 2007-09-28 18:35:23.000000000 +0200
++++ guichan-0.6.1/src/sdl/Makefile.am 2007-09-28 18:35:51.000000000 +0200
+@@ -10,3 +10,5 @@
+ sdlimage.cpp \
+ sdlimageloader.cpp \
+ sdlinput.cpp
++
++libguichan_sdl_la_LDFLAGS = @SDL_LIBS@
diff --git a/recipes/guichan/guichan_0.7.1.bb b/recipes/guichan/guichan_0.7.1.bb
new file mode 100644
index 0000000000..83a9eca2c5
--- /dev/null
+++ b/recipes/guichan/guichan_0.7.1.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "A portable C++ GUI library designed for games using Allegro, HGE, OpenGL, OpenLayer and/or SDL."
+HOMEPAGE = "http://guichan.sourceforge.net"
+DEPENDS = "virtual/libsdl libsdl-image"
+PR = "r1"
+
+SRC_URI = "http://guichan.googlecode.com/files/${PN}-${PV}.tar.gz \
+ file://link-against-sdlimage.patch;patch=1"
+
+inherit autotools
+
+EXTRA_OECONF = "--disable-opengl --disable-glut --disable-allegro \
+ --enable-sdlimage --enable-sdl"
+
+PACKAGES =+ "libguichan libguichan-sdl"
+
+FILES_libguichan = "${libdir}/libguichan.so.*"
+FILES_libguichan-sdl = "${libdir}/libguichan_sdl.so.*"
+
+do_stage () {
+ autotools_stage_all
+}
+