aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/guile/guile-native_1.8.5.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/guile/guile-native_1.8.5.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/guile/guile-native_1.8.5.bb')
-rw-r--r--recipes/guile/guile-native_1.8.5.bb137
1 files changed, 137 insertions, 0 deletions
diff --git a/recipes/guile/guile-native_1.8.5.bb b/recipes/guile/guile-native_1.8.5.bb
new file mode 100644
index 0000000000..e73616e6eb
--- /dev/null
+++ b/recipes/guile/guile-native_1.8.5.bb
@@ -0,0 +1,137 @@
+SECTION = "unknown"
+LICENSE = "GPL"
+DEPENDS = "gmp-native"
+SRC_URI = "http://ftp.gnu.org/pub/gnu/guile/guile-${PV}.tar.gz \
+ file://configure-fix.patch;patch=1 \
+"
+
+PR = "r1"
+
+inherit autotools native
+
+S="${WORKDIR}/guile-${PV}"
+
+OE_LT_RPATH_ALLOW = "any"
+LDFLAGS += " -L${STAGING_LIBDIR} "
+
+LIBGUILE_HEADERS = "\
+__scm.h \
+alist.h \
+arbiters.h \
+async.h \
+backtrace.h \
+boolean.h \
+chars.h \
+continuations.h \
+debug-malloc.h \
+debug.h \
+deprecation.h \
+dynl.h \
+dynwind.h \
+environments.h \
+eq.h \
+error.h \
+eval.h \
+evalext.h \
+extensions.h \
+feature.h \
+filesys.h \
+fluids.h \
+fports.h \
+gc.h \
+gdb_interface.h \
+gdbint.h \
+goops.h \
+gsubr.h \
+guardians.h \
+hash.h \
+hashtab.h \
+hooks.h \
+init.h \
+ioext.h \
+iselect.h \
+keywords.h \
+lang.h \
+list.h \
+load.h \
+macros.h \
+mallocs.h \
+modules.h \
+net_db.h \
+numbers.h \
+objects.h \
+objprop.h \
+options.h \
+pairs.h \
+ports.h \
+posix.h \
+print.h \
+procprop.h \
+procs.h \
+properties.h \
+ramap.h \
+random.h \
+rdelim.h \
+read.h \
+regex-posix.h \
+root.h \
+rw.h \
+scmconfig.h \
+scmsigs.h \
+script.h \
+simpos.h \
+smob.h \
+snarf.h \
+socket.h \
+sort.h \
+srcprop.h \
+stackchk.h \
+stacks.h \
+stime.h \
+strings.h \
+strorder.h \
+strports.h \
+struct.h \
+symbols.h \
+tags.h \
+threads.h \
+throw.h \
+unif.h \
+validate.h \
+values.h \
+variable.h \
+vectors.h \
+version.h \
+vports.h \
+weaks.h \
+"
+
+do_stage() {
+ install -d ${STAGING_INCDIR}/libguile
+ for i in ${LIBGUILE_HEADERS}; do
+ install -m 0644 libguile/$i ${STAGING_INCDIR}/libguile/$i
+ done
+
+ install -d ${STAGING_BINDIR_NATIVE}
+ install -m 0755 ${S}/libguile/.libs/guile ${STAGING_BINDIR_NATIVE}/
+
+ install -m 0644 libguile.h ${STAGING_INCDIR}/libguile.h
+ install -d ${STAGING_INCDIR}/guile
+ install -m 0644 libguile/gh.h ${STAGING_INCDIR}/guile/
+ install -d ${STAGING_INCDIR}/guile/srfi
+ install -d ${STAGING_INCDIR}/guile-readline
+ install -m 0644 guile-readline/readline.h ${STAGING_INCDIR}/guile-readline/
+ install -d ${STAGING_DATADIR}/aclocal
+ install -m 0644 guile-config/guile.m4 ${STAGING_DATADIR}/aclocal
+
+ install -d ${STAGING_DATADIR}/guile/1.8
+ cp -pPr ${S}/ice-9 ${STAGING_DATADIR}/guile/1.8/
+
+ oe_libinstall -C guile-readline -so -a libguilereadline-v-17 ${STAGING_LIBDIR}
+ oe_libinstall -C libguile -so -a libguile ${STAGING_LIBDIR}
+}
+
+do_configure_append() {
+ find ${S} -name Makefile | xargs sed -i s:'-Werror':'':g
+}
+