aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/guile/guile_1.8.5.bb
diff options
context:
space:
mode:
authorDenis 'Gnutoo' Carikli <GNUtoo@no-log.org>2009-06-09 15:20:41 +0200
committerDenis 'Gnutoo' Carikli <GNUtoo@no-log.org>2009-06-09 16:02:20 +0200
commit9819c4c798ef82ee515a88fd900924ce768e75a7 (patch)
tree7672c35b411f17d79c372de15616772e9a0690c3 /recipes/guile/guile_1.8.5.bb
parente91abf92fe3b55ed7a1bed4d75004a5df0b164be (diff)
downloadopenembedded-9819c4c798ef82ee515a88fd900924ce768e75a7.tar.gz
guile: added guile and guile-native 1.8.6 using .inc files
*not bumping PR of 1.8.5 becuase the result of the recipe doesn't change *guile 1.8.6 works with libtool 2.x: http://git.savannah.gnu.org/gitweb/?p=guile.git;a=blob;f=NEWS;h=d5c6771d09f5a181122cf16c0723f02182314704;hb=43ec70085aad9fa368e7f64080427d40fa68c47b) while guile 1.8.5 doesn't: http://www.mail-archive.com/bug-guile@gnu.org/msg04579.html
Diffstat (limited to 'recipes/guile/guile_1.8.5.bb')
-rw-r--r--recipes/guile/guile_1.8.5.bb50
1 files changed, 4 insertions, 46 deletions
diff --git a/recipes/guile/guile_1.8.5.bb b/recipes/guile/guile_1.8.5.bb
index 86eefa04c6..0a6ddce165 100644
--- a/recipes/guile/guile_1.8.5.bb
+++ b/recipes/guile/guile_1.8.5.bb
@@ -1,50 +1,8 @@
-DESCRIPTION = "Guile is an interpreter for the Scheme programming language, \
-packaged as a library which can be incorporated into your programs."
-HOMEPAGE = "http://www.gnu.org/software/guile/guile.html"
-SECTION = "devel/scheme"
-DEPENDS = "guile-native gmp libtool"
-LICENSE = "GPL"
-PACKAGES =+ "${PN}-el"
-FILES_${PN}-el = "${datadir}/emacs"
-DESCRIPTION_${PN}-el = "Emacs lisp files for Guile"
-
-PR = "r4"
+require guile.inc
SRC_URI = "http://ftp.gnu.org/pub/gnu/guile/guile-${PV}.tar.gz \
- file://configure-fix.patch;patch=1 "
-
-inherit autotools
-
-acpaths = "-I ${S}/guile-config"
+ file://configure-fix.patch;patch=1 \
+ "
-EXTRA_OECONF = " \
- --without-threads \
- --without-included-ltdl \
- "
-
-do_compile() {
- for i in $(find ${S} -name "Makefile") ; do
- sed -i -e s:-Werror::g $i
- done
-
- (cd libguile; oe_runmake CC="${BUILD_CC}" CFLAGS="${BUILD_CFLAGS}" LDFLAGS="${BUILD_LDFLAGS}" guile_filter_doc_snarfage)
- oe_runmake preinstguile="`which guile`"
-
- sed -i -e s:${STAGING_DIR_TARGET}::g \
- -e s:/${TARGET_SYS}::g \
- -e s:-L/usr/lib::g \
- -e s:-isystem/usr/include::g \
- -e s:,/usr/lib:,\$\{libdir\}:g \
- guile-1.8.pc
-}
+PR = "r4"
-do_stage() {
- autotools_stage_all
- # Create guile-config returning target values instead of native values
- install -d ${STAGING_BINDIR_CROSS}
- echo '#!'`which guile`$' \\\n-e main -s\n!#\n(define %guile-build-info '\'\( >guile-config.cross
- sed -n $'s:-isystem[^ ]* ::;s:-Wl,-rpath-link,[^ ]* ::;s:^[ \t]*{[ \t]*": (:;s:",[ \t]*": . ":;s:" *}, *\\\\:"):;/^ (/p' <libguile/libpath.h >>guile-config.cross
- echo '))' >>guile-config.cross
- cat guile-config/guile-config >>guile-config.cross
- install guile-config.cross ${STAGING_BINDIR_CROSS}/guile-config
-}