aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gutenprint
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/gutenprint
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/gutenprint')
-rw-r--r--recipes/gutenprint/gutenprint-native_5.1.3.bb39
-rw-r--r--recipes/gutenprint/gutenprint.inc28
-rw-r--r--recipes/gutenprint/gutenprint_5.1.3.bb48
-rw-r--r--recipes/gutenprint/ijs_0.35.bb15
4 files changed, 130 insertions, 0 deletions
diff --git a/recipes/gutenprint/gutenprint-native_5.1.3.bb b/recipes/gutenprint/gutenprint-native_5.1.3.bb
new file mode 100644
index 0000000000..4fe56d6c59
--- /dev/null
+++ b/recipes/gutenprint/gutenprint-native_5.1.3.bb
@@ -0,0 +1,39 @@
+SECTION = "libs"
+require gutenprint_${PV}.bb
+DEPENDS = ""
+inherit native
+
+EXTRA_OECONF = "\
+ --disable-nls \
+ --disable-gtktest \
+ --enable-cups-ppds \
+ --disable-libgutenprintui \
+ --disable-libgutenprintui2 \
+ --disable-translated-cups-ppds \
+ --with-ghostscript \
+ --enable-cups-level3-ppds \
+ --disable-gimptest \
+ --enable-test \
+ --enable-epson \
+ --with-user-guide \
+ --with-samples \
+ --with-escputil \
+ "
+
+do_configure() {
+ gnu-configize
+ libtoolize --force
+ oe_runconf
+}
+
+
+
+
+do_stage() {
+ autotools_stage_includes
+ install -m 0755 -d ${STAGING_DATADIR}/cups/model
+ install -m 0644 src/cups/ppd/C/*ppd* ${STAGING_DATADIR}/cups/model/
+# oe_libinstall -so -a -C objs libfreetype ${STAGING_LIBDIR}
+}
+
+
diff --git a/recipes/gutenprint/gutenprint.inc b/recipes/gutenprint/gutenprint.inc
new file mode 100644
index 0000000000..961613036a
--- /dev/null
+++ b/recipes/gutenprint/gutenprint.inc
@@ -0,0 +1,28 @@
+DESCRIPTION = "Gutenprint printer drivers"
+HOMEPAGE = "http://gimp-print.sourceforge.net/"
+LICENSE = "GPL"
+
+DEPENDS = "glib-2.0 cups tiff jpeg libpng gutenprint-native espgs"
+
+
+inherit autotools pkgconfig
+PARALLEL_MAKE=""
+
+#EXTRA_OECONF = "\
+# --disable-nls \
+# --disable-gtktest \
+# --enable-cups-ppds \
+# --disable-libgutenprintui \
+# --disable-libgutenprintui2 \
+# --disable-translated-cups-ppds \
+# --with-ghostscript \
+# --enable-cups-level3-ppds \
+# --disable-gimptest \
+# --enable-test \
+# --enable-epson \
+# --with-user-guide \
+# --with-samples \
+# --with-escputil \
+# "
+
+
diff --git a/recipes/gutenprint/gutenprint_5.1.3.bb b/recipes/gutenprint/gutenprint_5.1.3.bb
new file mode 100644
index 0000000000..f0e0b734ab
--- /dev/null
+++ b/recipes/gutenprint/gutenprint_5.1.3.bb
@@ -0,0 +1,48 @@
+require gutenprint.inc
+
+PR = "r1"
+
+DEPENDS = "glib-2.0 ijs ncurses cups tiff jpeg libpng gutenprint-native espgs"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/gimp-print/gutenprint-5.1.3.tar.bz2"
+S = "${WORKDIR}/gutenprint-${PV}"
+
+
+EXTRA_OECONF = "\
+ --disable-nls \
+ --disable-gtktest \
+# --enable-cups-ppds \
+# this option is disabled here, since the ppds are generated during native build
+ --disable-libgutenprintui \
+ --disable-libgutenprintui2 \
+ --disable-translated-cups-ppds \
+# --with-ghostscript \
+# i MAY have to disable this one as well, since these are probably built in native as well
+ --enable-cups-level3-ppds \
+ --disable-gimptest \
+ --enable-test \
+ --enable-epson \
+ --with-user-guide \
+ --with-samples \
+ --with-escputil \
+ "
+
+do_configure() {
+ gnu-configize
+ libtoolize --force
+ oe_runconf
+}
+
+
+do_install_append() {
+ install -d ${D}${datadir}/cups/model/
+ install -m 644 ${STAGING_DATADIR_NATIVE}/cups/model/* ${D}${datadir}/cups/model/
+ cp -pPr ${D}${STAGING_LIBDIR}/* ${D}${libdir}/
+ cp -pPr ${D}${STAGING_DATADIR}/* ${D}${datadir}/
+}
+
+
+FILES_${PN} += "${datadir}/cups/model ${libdir}/cups ${datadir}/cups/calibrate.ppm"
+FILES_${PN}-dbg += "${libdir}/cups/*/.debug"
+
+
diff --git a/recipes/gutenprint/ijs_0.35.bb b/recipes/gutenprint/ijs_0.35.bb
new file mode 100644
index 0000000000..18407480c9
--- /dev/null
+++ b/recipes/gutenprint/ijs_0.35.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "Inkjet driver from linuxprinting.org"
+LICENSE = "MIT"
+HOMEPAGE = "http://www.linuxprinting.org/ijs/"
+
+SRC_URI = "http://www.linuxprinting.org/ijs/download/ijs-${PV}.tar.bz2"
+
+inherit autotools pkgconfig binconfig lib_package
+
+EXTRA_OECONF = " --enable-shared "
+
+do_stage() {
+ autotools_stage_all
+}
+
+