aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gxine/gxine_0.4.1.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/gxine/gxine_0.4.1.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/gxine/gxine_0.4.1.bb')
-rw-r--r--recipes/gxine/gxine_0.4.1.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/recipes/gxine/gxine_0.4.1.bb b/recipes/gxine/gxine_0.4.1.bb
new file mode 100644
index 0000000000..9648e9ef0c
--- /dev/null
+++ b/recipes/gxine/gxine_0.4.1.bb
@@ -0,0 +1,44 @@
+DESCRIPTION = "gxine is a front-end for libxine."
+SECTION = "x11/multimedia"
+LICENSE = "GPL"
+DEPENDS = "gtk+ libxine-x11"
+PR = "r2"
+
+DEFAULT_PREFERENCE = "-1"
+
+# Long list of RDEPENDS required to playback mp3/ogg audio and mpeg/mpeg4 video
+RDEPENDS = "libxine-plugin-vo-out-xshm \
+ libxine-plugin-vo-out-none \
+ libxine-plugin-ao-out-esd \
+ libxine-plugin-ao-out-none \
+ libxine-plugin-inp-file \
+ libxine-plugin-inp-http \
+ libxine-plugin-inp-net \
+ libxine-plugin-inp-mms \
+ libxine-plugin-decode-mad \
+ libxine-plugin-decode-vorbis \
+ libxine-plugin-decode-image \
+ libxine-plugin-decode-ff \
+ libxine-plugin-dmx-audio \
+ libxine-plugin-dmx-mpeg \
+ libxine-plugin-dmx-mpeg-block \
+ libxine-plugin-dmx-mpeg-elem \
+ libxine-plugin-dmx-mpeg-pes \
+ libxine-plugin-dmx-mpeg-ts \
+ libxine-plugin-dmx-ogg \
+ libxine-plugin-dmx-image \
+ libxine-plugin-dmx-avi"
+
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/xine/${PN}-${PV}.tar.gz \
+ file://disable-browser-plugin.patch;patch=1"
+
+EXTRA_OECONF = " --includedir=${STAGING_INCDIR} \
+ --libdir=${STAGING_LIBDIR} \
+ --disable-xinetest \
+ --with-xine-prefix=${STAGING_DIR_HOST}${layout_exec_prefix}"
+
+LDFLAGS += "-lxine"
+
+inherit autotools pkgconfig
+