aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gypsy
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/gypsy
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/gypsy')
-rw-r--r--recipes/gypsy/files/docs-reference-am.patch17
-rw-r--r--recipes/gypsy/files/fixups.patch14
-rw-r--r--recipes/gypsy/gypsy.inc16
-rw-r--r--recipes/gypsy/gypsy_svn.bb9
4 files changed, 56 insertions, 0 deletions
diff --git a/recipes/gypsy/files/docs-reference-am.patch b/recipes/gypsy/files/docs-reference-am.patch
new file mode 100644
index 0000000000..9eb0051d79
--- /dev/null
+++ b/recipes/gypsy/files/docs-reference-am.patch
@@ -0,0 +1,17 @@
+Index: gypsy/docs/reference/Makefile.am
+===================================================================
+--- gypsy.orig/docs/reference/Makefile.am 2008-03-10 13:15:06.000000000 +0800
++++ gypsy/docs/reference/Makefile.am 2008-03-10 13:15:24.000000000 +0800
+@@ -88,10 +88,10 @@
+
+ # Other files to distribute
+ # e.g. EXTRA_DIST += version.xml.in
+-EXTRA_DIST += version.xml.in \
++EXTRA_DIST = version.xml.in \
+ gypsy-design.png
+
+-CLEANFILES += $(dbus_docs)
++CLEANFILES = $(dbus_docs)
+
+ ref-%.xml: $(top_srcdir)/interfaces/%-full.xml
+ $(XSLT) -o $@ $(top_srcdir)/docs/tools/spec-to-docbook.xsl $<
diff --git a/recipes/gypsy/files/fixups.patch b/recipes/gypsy/files/fixups.patch
new file mode 100644
index 0000000000..1f64d58513
--- /dev/null
+++ b/recipes/gypsy/files/fixups.patch
@@ -0,0 +1,14 @@
+---
+ docs/reference/Makefile.am | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+Index: gypsy/docs/reference/Makefile.am
+===================================================================
+--- gypsy.orig/docs/reference/Makefile.am 2007-10-04 23:04:44.000000000 +0100
++++ gypsy/docs/reference/Makefile.am 2007-10-04 23:04:53.000000000 +0100
+@@ -82,4 +82,4 @@ include $(top_srcdir)/gtk-doc.make
+
+ # Other files to distribute
+ # e.g. EXTRA_DIST += version.xml.in
+-EXTRA_DIST +=
++# EXTRA_DIST =
diff --git a/recipes/gypsy/gypsy.inc b/recipes/gypsy/gypsy.inc
new file mode 100644
index 0000000000..df5e1c7da3
--- /dev/null
+++ b/recipes/gypsy/gypsy.inc
@@ -0,0 +1,16 @@
+DESCRIPTION = "GPS Controlling Daemon"
+LICENSE = "GPL"
+SECTION = "x11"
+DEPENDS = "glib-2.0 dbus-glib bluez-libs libxslt-native"
+
+inherit autotools pkgconfig
+
+do_configure_prepend () {
+ touch ${S}/gtk-doc.make
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
+FILES_${PN} += "${datadir}/dbus-1/services/"
diff --git a/recipes/gypsy/gypsy_svn.bb b/recipes/gypsy/gypsy_svn.bb
new file mode 100644
index 0000000000..1fcc47e828
--- /dev/null
+++ b/recipes/gypsy/gypsy_svn.bb
@@ -0,0 +1,9 @@
+require gypsy.inc
+
+SRC_URI = "svn://svn.o-hand.com/repos/${PN}/trunk;module=${PN};proto=http \
+ file://fixups.patch;patch=1;maxrev=107 \
+ file://docs-reference-am.patch;patch=1;minrev=134"
+S = "${WORKDIR}/${PN}"
+
+PV = "0.0+svnr${SRCREV}"
+PR = "r1"