aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/h2200-bootloader
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/h2200-bootloader
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/h2200-bootloader')
-rw-r--r--recipes/h2200-bootloader/h2200-bootloader.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/recipes/h2200-bootloader/h2200-bootloader.bb b/recipes/h2200-bootloader/h2200-bootloader.bb
new file mode 100644
index 0000000000..5db3cd058d
--- /dev/null
+++ b/recipes/h2200-bootloader/h2200-bootloader.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "Bootloader firmware extractor for the h2200 iPAQ"
+RRECOMMENDS_${PN} = "kernel-module-mtdblock"
+ALLOW_EMPTY = "1"
+PR = "r3"
+
+COMPATIBLE_MACHINE = "h2200"
+#it is a shell script, but lets protect the innocent some more
+PACKAGE_ARCH = "h2200"
+
+pkg_postinst() {
+#!/bin/sh
+mkdir -p /lib/firmware
+modprobe mtdblock
+dd if=/dev/mtdblock0 of=/lib/firmware/h2200_bootloader.bin 2>/dev/null
+}