aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/hal/files
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/hal/files
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/hal/files')
-rw-r--r--recipes/hal/files/20hal58
-rw-r--r--recipes/hal/files/99_hal2
-rw-r--r--recipes/hal/files/autoconf.diff11
-rw-r--r--recipes/hal/files/dbus-fix-api.patch26
-rw-r--r--recipes/hal/files/hal-right-input-h.patch29
-rw-r--r--recipes/hal/files/sg-inhibit.patch24
6 files changed, 150 insertions, 0 deletions
diff --git a/recipes/hal/files/20hal b/recipes/hal/files/20hal
new file mode 100644
index 0000000000..926bd893e2
--- /dev/null
+++ b/recipes/hal/files/20hal
@@ -0,0 +1,58 @@
+#! /bin/sh
+#
+# hal Start the Daemon that stores device informations
+# for the Hardware abstraction layer
+#
+# Written by Martin Waitz based on skeleton code
+# written by Miquel van Smoorenburg <miquels@cistron.nl>.
+# Modified for Debian
+# by Ian Murdock <imurdock@gnu.ai.mit.edu>.
+#
+
+PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin
+DAEMON=/usr/sbin/hald
+PIDDIR=/var/run/hald
+PIDFILE=$PIDDIR/pid
+NAME=hald
+DAEMONUSER=haldaemon
+DESC="Hardware abstraction layer"
+
+test -x $DAEMON || exit 0
+
+set -e
+
+do_start() {
+ if [ ! -d $PIDDIR ]; then
+ mkdir -p $PIDDIR
+ chown $DAEMONUSER:$DAEMONUSER $PIDDIR
+ fi
+ echo "Starting $DESC" "$NAME"
+ start-stop-daemon --start --pidfile $PIDFILE \
+ --exec $DAEMON -- $DAEMON_OPTS
+}
+
+do_stop() {
+ echo "Stopping $DESC" "$NAME"
+ start-stop-daemon --stop --quiet --pidfile $PIDFILE \
+ --exec $DAEMON
+}
+
+case "$1" in
+ start)
+ do_start
+ ;;
+ stop)
+ do_stop
+ ;;
+ restart|force-reload)
+ do_stop
+ sleep 5
+ do_start
+ ;;
+ *)
+ echo "Usage: $0 {start|stop|restart|force-reload}" >&2
+ exit 1
+ ;;
+esac
+
+exit 0
diff --git a/recipes/hal/files/99_hal b/recipes/hal/files/99_hal
new file mode 100644
index 0000000000..c82da990ba
--- /dev/null
+++ b/recipes/hal/files/99_hal
@@ -0,0 +1,2 @@
+d root root 0700 /var/run/hald none
+d haldaemon haldaemon 0755 /var/cache/hald none
diff --git a/recipes/hal/files/autoconf.diff b/recipes/hal/files/autoconf.diff
new file mode 100644
index 0000000000..eb30cccdbe
--- /dev/null
+++ b/recipes/hal/files/autoconf.diff
@@ -0,0 +1,11 @@
+--- hal-0.5.9/configure.in~ 2007-04-03 05:36:44.000000000 +0100
++++ hal-0.5.9/configure.in 2007-04-03 10:29:39.000000000 +0100
+@@ -6,7 +6,7 @@
+ # Patches for that is welcome.
+ #
+
+-AC_PREREQ(2.59c)
++AC_PREREQ(2.59)
+ AC_INIT(hal, 0.5.9, david@fubar.dk)
+ AM_INIT_AUTOMAKE(hal, 0.5.9)
+ AM_CONFIG_HEADER(config.h)
diff --git a/recipes/hal/files/dbus-fix-api.patch b/recipes/hal/files/dbus-fix-api.patch
new file mode 100644
index 0000000000..1f025870bc
--- /dev/null
+++ b/recipes/hal/files/dbus-fix-api.patch
@@ -0,0 +1,26 @@
+Index: hal-0.5.7/tools/lshal.c
+===================================================================
+--- hal-0.5.7.orig/tools/lshal.c 2006-02-13 14:35:31.000000000 +0000
++++ hal-0.5.7/tools/lshal.c 2006-11-09 13:48:07.000000000 +0000
+@@ -701,7 +701,7 @@
+ libhal_ctx_shutdown (hal_ctx, &error);
+ libhal_ctx_free (hal_ctx);
+
+- dbus_connection_disconnect (conn);
++ dbus_connection_close (conn);
+ dbus_connection_unref (conn);
+
+ if (show_device)
+Index: hal-0.5.7/tools/hal-device.c
+===================================================================
+--- hal-0.5.7.orig/tools/hal-device.c 2006-11-09 13:49:44.000000000 +0000
++++ hal-0.5.7/tools/hal-device.c 2006-11-09 13:50:00.000000000 +0000
+@@ -155,7 +155,7 @@
+
+ libhal_ctx_shutdown(hal_ctx, &error);
+ libhal_ctx_free(hal_ctx);
+- dbus_connection_disconnect(conn);
++ dbus_connection_close(conn);
+ dbus_connection_unref(conn);
+ dbus_error_free(&error);
+
diff --git a/recipes/hal/files/hal-right-input-h.patch b/recipes/hal/files/hal-right-input-h.patch
new file mode 100644
index 0000000000..f820b7790a
--- /dev/null
+++ b/recipes/hal/files/hal-right-input-h.patch
@@ -0,0 +1,29 @@
+diff --git a/configure.in b/configure.in
+index e76ff51..5e8cc21 100644
+--- a/configure.in
++++ b/configure.in
+@@ -983,6 +983,11 @@ AC_ARG_WITH([linux-input-header],
+ [Use an given Linux input.h rather than that installed on the system (<linux/input.h>)]))
+ if test "x$with_linux_input_header" != "x"; then
+ AC_DEFINE_UNQUOTED(HAL_LINUX_INPUT_HEADER_H, "$with_linux_input_header", [If set, the header to use instead of <linux/input.h>])
++ LINUX_INPUT_H=$with_linux_input_header
++ AC_SUBST(LINUX_INPUT_H)
++else
++ LINUX_INPUT_H=/usr/include/linux/input.h
++ AC_SUBST(LINUX_INPUT_H)
+ fi
+
+ dnl
+diff --git a/tools/Makefile.am b/tools/Makefile.am
+index ae03edd..7d1cbab 100644
+--- a/tools/Makefile.am
++++ b/tools/Makefile.am
+@@ -79,7 +79,7 @@ endif
+ if BUILD_KEYMAPS
+
+ if HAVE_GPERF
+-hal-setup-keymap-keys.txt: /usr/include/linux/input.h
++hal-setup-keymap-keys.txt: @LINUX_INPUT_H@
+ awk '/^#define.*KEY_/ { if ($$2 != "KEY_MAX") { print substr($$2, 5) } }' < $< > $@
+
+ hal-setup-keymap-hash-name.gperf: hal-setup-keymap-keys.txt
diff --git a/recipes/hal/files/sg-inhibit.patch b/recipes/hal/files/sg-inhibit.patch
new file mode 100644
index 0000000000..f0cc41448a
--- /dev/null
+++ b/recipes/hal/files/sg-inhibit.patch
@@ -0,0 +1,24 @@
+--- hal-0.5.9.1/hald/linux/probing/linux_dvd_rw_utils.c.old 2007-08-03 17:24:12.000000000 +0100
++++ hal-0.5.9.1/hald/linux/probing/linux_dvd_rw_utils.c 2007-08-03 17:25:06.000000000 +0100
+@@ -58,6 +58,10 @@
+
+ #include "linux_dvd_rw_utils.h"
+
++#if defined(SG_FLAG_UNUSED_LUN_INHIBIT)
++# define SG_FLAG_LUN_INHIBIT SG_FLAG_UNUSED_LUN_INHIBIT
++#endif
++
+ typedef enum {
+ NONE = CGC_DATA_NONE, // 3
+ READ = CGC_DATA_READ, // 2
+@@ -153,8 +153,8 @@
+ errno = EIO;
+ ret = -1;
+ if (cmd->sg_io.masked_status & CHECK_CONDITION) {
+- CREAM_ON_ERRNO (cmd->sg_io.sbp);
+- ret = ERRCODE (cmd->sg_io.sbp);
++ CREAM_ON_ERRNO ((char*)cmd->sg_io.sbp);
++ ret = ERRCODE ((char*)cmd->sg_io.sbp);
+ if (ret == 0)
+ ret = -1;
+ }