aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/hal
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-01-25 12:01:50 +0100
committerKoen Kooi <koen@openembedded.org>2010-01-25 12:29:40 +0100
commit10a12580ea61040615590dc9fe442d3de79a38a1 (patch)
treec8703e3ff2d2e91cba36b4faba71eb7edf45aac7 /recipes/hal
parentb31b8aa5b7183a75c5e68e755f1f4736cbc9e2c6 (diff)
downloadopenembedded-10a12580ea61040615590dc9fe442d3de79a38a1.tar.gz
hal 0.5.14+git: teach linux devices.c about 'input.touchscreen'
Diffstat (limited to 'recipes/hal')
-rw-r--r--recipes/hal/hal/0001-Add-touchscreen-option.patch28
-rw-r--r--recipes/hal/hal_0.5.14+git.bb2
2 files changed, 30 insertions, 0 deletions
diff --git a/recipes/hal/hal/0001-Add-touchscreen-option.patch b/recipes/hal/hal/0001-Add-touchscreen-option.patch
new file mode 100644
index 0000000000..28c30f5250
--- /dev/null
+++ b/recipes/hal/hal/0001-Add-touchscreen-option.patch
@@ -0,0 +1,28 @@
+From e2614c85992663c006184141e552f8b6920a9873 Mon Sep 17 00:00:00 2001
+From: Koen Kooi <koen@dominion.thruhere.net>
+Date: Mon, 25 Jan 2010 10:58:14 +0100
+Subject: [PATCH] Add touchscreen option
+
+If a device sets the ABS_PRESSURE bit mark it as a touchscreen
+---
+ hald/linux/device.c | 4 ++++
+ 1 files changed, 4 insertions(+), 0 deletions(-)
+
+diff --git a/hald/linux/device.c b/hald/linux/device.c
+index e7c9d4f..a4ff96f 100644
+--- a/hald/linux/device.c
++++ b/hald/linux/device.c
+@@ -1181,6 +1181,10 @@ input_test_abs (HalDevice *d, const char *sysfs_path)
+ goto out;
+ }
+ }
++ if (test_bit (ABS_PRESSURE, bitmask_abs)) {
++ hal_device_add_capability (d, "input.touchscreen");
++ goto out;
++ }
+ }
+ out:
+ ;
+--
+1.6.5
+
diff --git a/recipes/hal/hal_0.5.14+git.bb b/recipes/hal/hal_0.5.14+git.bb
index dfbf60d11f..6a842cf047 100644
--- a/recipes/hal/hal_0.5.14+git.bb
+++ b/recipes/hal/hal_0.5.14+git.bb
@@ -4,12 +4,14 @@ DEFAULT_PREFERENCE = "-1"
DEFAULT_PREFERENCE_angstrom = "1"
SRC_URI = "git://anongit.freedesktop.org/hal/;protocol=git \
+ file://0001-Add-touchscreen-option.patch;patch=1 \
file://20hal \
file://99_hal"
SRCREV = "6dccf8e3ad181e8f56b1d2a994ec50a1953a1c2d"
PV = "0.5.14"
+PR = "r1"
PR_append = "+gitr${SRCREV}"
S = "${WORKDIR}/git"