aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/hal
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2011-01-14 15:36:12 -0200
committerOtavio Salvador <otavio@ossystems.com.br>2011-01-16 15:55:35 -0200
commit4b8d851deb3dd746837a1ebec2d9caebd1934aec (patch)
tree615b08a53e5bb7f6ab77ebb045390b40d2c9a36a /recipes/hal
parent00abeb986a6aa14864a7787b836e514218b3ca19 (diff)
downloadopenembedded-4b8d851deb3dd746837a1ebec2d9caebd1934aec.tar.gz
hal: drop git and 0.5.9.1 versions since no distro uses them
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes/hal')
-rw-r--r--recipes/hal/hal_0.5.9.1.bb95
-rw-r--r--recipes/hal/hal_git.bb88
2 files changed, 0 insertions, 183 deletions
diff --git a/recipes/hal/hal_0.5.9.1.bb b/recipes/hal/hal_0.5.9.1.bb
deleted file mode 100644
index ef4b0446bb..0000000000
--- a/recipes/hal/hal_0.5.9.1.bb
+++ /dev/null
@@ -1,95 +0,0 @@
-DESCRIPTION = "Hardware Abstraction Layer"
-HOMEPAGE = "http://freedesktop.org/Software/hal"
-SECTION = "unknown"
-LICENSE = "GPL LGPL AFL"
-
-DEPENDS = "virtual/kernel dbus-glib udev intltool-native expat virtual/libusb0"
-RDEPENDS_${PN} += "udev-utils hal-info"
-
-PR = "r10"
-
-SRC_URI = "http://freedesktop.org/~david/dist/hal-${PV}.tar.gz \
- file://configure_fix.patch \
- file://sg-inhibit.patch \
- file://20hal \
- file://99_hal"
-
-S = "${WORKDIR}/hal-${PV}"
-
-inherit autotools pkgconfig
-
-EXTRA_OECONF = "--with-hwdata=${datadir}/hwdata \
- --with-expat=${STAGING_DIR_HOST}${layout_prefix} \
- --with-dbus-sys=${sysconfdir}/dbus-1/system.d \
- --with-hotplug=${sysconfdir}/hotplug.d \
- --disable-docbook-docs \
- --disable-policy-kit \
- --disable-acpi --disable-acpi-acpid --disable-acpi-proc \
- --disable-sonypic \
- --disable-pmu --disable-pci \
- --disable-pci-ids --disable-pnp-ids \
- "
-
-do_install_append() {
- install -d ${D}/etc/default/volatiles
- install -m 0644 ${WORKDIR}/99_hal ${D}/etc/default/volatiles
- install -d ${D}/etc/dbus-1/event.d
- install -m 0755 ${WORKDIR}/20hal ${D}/etc/dbus-1/event.d
-}
-
-do_stage() {
- autotools_stage_all
- install -d ${STAGING_LIBDIR}
- install -m 755 libhal/.libs/libhal.so.1.0.0 ${STAGING_LIBDIR}/libhal.so
- install -m 755 libhal-storage/.libs/libhal-storage.so.1.0.0 ${STAGING_LIBDIR}/libhal-storage.so
-}
-
-# At the time the postinst runs, dbus might not be setup so only restart if running
-pkg_postinst_hal () {
- # can not do this offline
- if [ "x$D" != "x" ]; then
- exit 1
- fi
-
- grep haldaemon /etc/group || addgroup haldaemon
- grep haldaemon /etc/passwd || adduser --disabled-password --system --home /var/run/hald --no-create-home haldaemon --ingroup haldaemon -g HAL
-
- /etc/init.d/populate-volatile.sh update
-
- DBUSPID=`pidof dbus-daemon`
-
- if [ "x$DBUSPID" != "x" ]; then
- /etc/init.d/dbus-1 reload
- fi
-}
-
-pkg_postrm_hal () {
- deluser haldaemon || true
- delgroup haldaemon || true
-}
-
-PACKAGES =+ "libhal libhal-storage"
-
-FILES_libhal = "${libdir}/libhal.so.*"
-FILES_libhal-storage = "${libdir}/libhal-storage.so.*"
-
-FILES_${PN} = "${sysconfdir} \
- ${bindir}/lshal \
- ${bindir}/hal-find-by-capability \
- ${bindir}/hal-find-by-property \
- ${bindir}/hal-device \
- ${bindir}/hal-get-property \
- ${bindir}/hal-set-property \
- ${bindir}/hal-lock \
- ${bindir}/hal-is-caller-locked-out \
- ${bindir}/hal-disable-polling \
- ${sbindir} \
- ${libdir}/libhal.so.* \
- ${libdir}/libhal-storage.so.* \
- ${libdir}/hal \
- ${libexecdir} \
- ${datadir}/hal/fdi \
- ${datadir}/hal/scripts"
-
-SRC_URI[md5sum] = "6a40f49f964e64358e53652038f3059f"
-SRC_URI[sha256sum] = "5dc5cf08502510a00cecd6e04ef006a74ba7ed4b31d25187b5efadd70a78733b"
diff --git a/recipes/hal/hal_git.bb b/recipes/hal/hal_git.bb
deleted file mode 100644
index 58f534d3e1..0000000000
--- a/recipes/hal/hal_git.bb
+++ /dev/null
@@ -1,88 +0,0 @@
-DESCRIPTION = "Hardware Abstraction Layer"
-HOMEPAGE = "http://freedesktop.org/Software/hal"
-SECTION = "unknown"
-LICENSE = "GPL LGPL AFL"
-
-DEFAULT_PREFERENCE = "-1"
-
-DEPENDS = "virtual/kernel dbus-glib udev intltool-native expat virtual/libusb0"
-RDEPENDS_${PN} += "udev-utils hal-info"
-
-SRC_URI = "git://anongit.freedesktop.org/hal/;protocol=git \
- file://20hal \
- file://99_hal"
-
-PV = "0.5.9.1+git${SRCDATE}"
-PR = "r8"
-
-S = "${WORKDIR}/git"
-
-inherit autotools pkgconfig
-
-EXTRA_OECONF = "--with-hwdata=${datadir}/hwdata \
- --with-expat=${STAGING_DIR_HOST}${layout_prefix} \
- --with-dbus-sys=${sysconfdir}/dbus-1/system.d \
- --with-hotplug=${sysconfdir}/hotplug.d \
- --disable-docbook-docs \
- --disable-policy-kit \
- --disable-acpi --disable-acpi-acpid --disable-acpi-proc \
- --disable-sonypic \
- --disable-pmu --disable-pci \
- --disable-pci-ids --disable-pnp-ids \
- "
-
-do_install_append() {
- install -d ${D}/etc/default/volatiles
- install -m 0644 ${WORKDIR}/99_hal ${D}/etc/default/volatiles
- install -d ${D}/etc/dbus-1/event.d
- install -m 0755 ${WORKDIR}/20hal ${D}/etc/dbus-1/event.d
-}
-
-do_stage() {
- autotools_stage_all
- install -d ${STAGING_LIBDIR}
- install -m 755 libhal/.libs/libhal.so.1.0.0 ${STAGING_LIBDIR}/libhal.so
- install -m 755 libhal-storage/.libs/libhal-storage.so.1.0.0 ${STAGING_LIBDIR}/libhal-storage.so
-}
-
-# At the time the postinst runs, dbus might not be setup so only restart if running
-pkg_postinst_hal () {
- # can't do this offline
- if [ "x$D" != "x" ]; then
- exit 1
- fi
-
- grep haldaemon /etc/group || addgroup haldaemon
- grep haldaemon /etc/passwd || adduser --disabled-password --system --home /var/run/hald --no-create-home haldaemon --ingroup haldaemon -g HAL
-
- /etc/init.d/populate-volatile.sh update
-
- DBUSPID=`pidof dbus-daemon`
-
- if [ "x$DBUSPID" != "x" ]; then
- /etc/init.d/dbus-1 reload
- fi
-}
-
-pkg_postrm_hal () {
- deluser haldaemon || true
- delgroup haldaemon || true
-}
-
-FILES_${PN} = "${sysconfdir} \
- ${bindir}/lshal \
- ${bindir}/hal-find-by-capability \
- ${bindir}/hal-find-by-property \
- ${bindir}/hal-device \
- ${bindir}/hal-get-property \
- ${bindir}/hal-set-property \
- ${bindir}/hal-lock \
- ${bindir}/hal-is-caller-locked-out \
- ${bindir}/hal-disable-polling \
- ${sbindir} \
- ${libdir}/libhal.so.* \
- ${libdir}/libhal-storage.so.* \
- ${libdir}/hal \
- ${libexecdir} \
- ${datadir}/hal/fdi \
- ${datadir}/hal/scripts"