aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/hal
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-07-21 12:30:22 +0200
committerKoen Kooi <koen@openembedded.org>2009-07-21 12:30:22 +0200
commitb7d44d5dcf9cfab6376c68f7dd17f283597d94a0 (patch)
tree9ec53d5a2fc74a40e5338f4f1a15258eb24e3b9d /recipes/hal
parent26f1c0270426754527864657dfcf90ba30c2c23d (diff)
downloadopenembedded-b7d44d5dcf9cfab6376c68f7dd17f283597d94a0.tar.gz
hal: update to 0.5.13
Diffstat (limited to 'recipes/hal')
-rw-r--r--recipes/hal/hal_0.5.13.bb12
1 files changed, 12 insertions, 0 deletions
diff --git a/recipes/hal/hal_0.5.13.bb b/recipes/hal/hal_0.5.13.bb
new file mode 100644
index 0000000000..c5d9f65c2c
--- /dev/null
+++ b/recipes/hal/hal_0.5.13.bb
@@ -0,0 +1,12 @@
+require hal.inc
+
+DEFAULT_PREFERENCE = "-1"
+
+# The following code finds the right linux/input.h,
+# which also works with external-toolchain/SDK
+do_configure() {
+ sed -i -e s:1.43:1.41:g ${S}/configure.in
+ linux_input_h=`echo "#include <linux/input.h>" | ${CPP} - | \
+ grep "linux\/input.h" | head -n 1 | awk -F '"' '{print $2}'`
+ autotools_do_configure --with-linux-input-header=${linux_input_h}
+}