aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/hal
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2009-04-24 17:29:33 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2009-05-20 23:15:14 -0300
commitffb4e8d7acd9487a7331610021ca25adf260f537 (patch)
tree036078949b735598f4c1a80f52a75e95466a00fa /recipes/hal
parent57c5f8879e63e9d1e53552edf258f56a9ce1a2b2 (diff)
downloadopenembedded-ffb4e8d7acd9487a7331610021ca25adf260f537.tar.gz
hal-cups-utils: add
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes/hal')
-rw-r--r--recipes/hal/hal-cups-utils_0.6.19.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes/hal/hal-cups-utils_0.6.19.bb b/recipes/hal/hal-cups-utils_0.6.19.bb
new file mode 100644
index 0000000000..289990e0f0
--- /dev/null
+++ b/recipes/hal/hal-cups-utils_0.6.19.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Utilities to detect and configure printers automatically"
+HOMEPAGE = "https://fedorahosted.org/hal-cups-utils/"
+SECTION = "console/utils"
+LICENSE = "GPLv2 CUPS"
+DEPENDS = "hal dbus cups"
+RDEPENDS_${PN} += "python-dbus python-pycups python-cupshelpers python-subprocess python-syslog usbutils"
+
+SRC_URI = "https://fedorahosted.org/releases/h/a/hal-cups-utils/hal-cups-utils-${PV}.tar.gz"
+S = "${WORKDIR}/${PN}-${PV}"
+
+inherit autotools
+
+PACKAGES += "cups-backend-hal"
+
+FILES_${PN} += "${libdir}/hal/* ${datadir}/hal/*"
+FILES_${PN}-dbg += "${libdir}/hal/.debug ${libdir}/cups/backend/.debug"
+FILES_cups-backend-hal += "${libdir}/cups/backend/*"
+
+EXTRA_OECONF = "--libexecdir=${libdir}/hal/scripts"
+
+do_configure_append() {
+ sed -i 's,^#!/bin/env python,#!/usr/bin/python,' systemv/hal_lpadmin
+}