aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/hal
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2009-04-30 11:55:06 +0100
committerGraeme Gregory <dp@xora.org.uk>2009-04-30 11:55:06 +0100
commit1fc726a2f3a193b3e59806cd69d50b8890bb5c28 (patch)
tree87074faa649dbc11b88bca6eb015b7eab1c21135 /recipes/hal
parent66efe0dabfba7ab973580c7ab0f29d74cbbb3c47 (diff)
downloadopenembedded-1fc726a2f3a193b3e59806cd69d50b8890bb5c28.tar.gz
hal/hal.inc : change hardcoded etc to ${sysconfdir} and remove bogus directory
hal/hal_0.5.11.bb : bump PR for above change
Diffstat (limited to 'recipes/hal')
-rw-r--r--recipes/hal/hal.inc17
-rw-r--r--recipes/hal/hal_0.5.11.bb2
2 files changed, 10 insertions, 9 deletions
diff --git a/recipes/hal/hal.inc b/recipes/hal/hal.inc
index f8ef0e4398..d17907ae79 100644
--- a/recipes/hal/hal.inc
+++ b/recipes/hal/hal.inc
@@ -36,10 +36,11 @@ PACKAGE_ARCH = "${@base_contains('MACHINE_FEATURES', 'acpi', '${MACHINE_ARCH}',
PACKAGE_ARCH = "${@base_contains('MACHINE_FEATURES', 'pci', '${MACHINE_ARCH}', '${MY_ARCH}',d)}"
do_install_append() {
- install -d ${D}/etc/default/volatiles
- install -m 0644 ${WORKDIR}/99_hal ${D}/etc/default/volatiles
- install -d ${D}/etc/dbus-1/event.d
- install -m 0755 ${WORKDIR}/20hal ${D}/etc/dbus-1/event.d
+ install -d ${D}/${sysconfdir}/default/volatiles
+ install -m 0644 ${WORKDIR}/99_hal ${D}/${sysconfdir}/default/volatiles
+ install -d ${D}/${sysconfdir}/dbus-1/event.d
+ install -m 0755 ${WORKDIR}/20hal ${D}/${sysconfdir}/dbus-1/event.d
+ rm -rf ${D}/${sysconfdir}/rc.d || true
}
do_stage() {
@@ -58,15 +59,15 @@ pkg_postinst_hal () {
exit 1
fi
- grep haldaemon /etc/group || addgroup haldaemon
- grep haldaemon /etc/passwd || adduser --disabled-password --system --home /var/run/hald --no-create-home haldaemon --ingroup haldaemon -g HAL
+ grep haldaemon ${sysconfdir}/group || addgroup haldaemon
+ grep haldaemon ${sysconfdir}/passwd || adduser --disabled-password --system --home /var/run/hald --no-create-home haldaemon --ingroup haldaemon -g HAL
- /etc/init.d/populate-volatile.sh update
+ ${sysconfdir}/init.d/populate-volatile.sh update
DBUSPID=`pidof dbus-daemon`
if [ "x$DBUSPID" != "x" ]; then
- /etc/init.d/dbus-1 force-reload
+ ${sysconfdir}/init.d/dbus-1 force-reload
fi
}
diff --git a/recipes/hal/hal_0.5.11.bb b/recipes/hal/hal_0.5.11.bb
index 3b5888a863..898ad07c92 100644
--- a/recipes/hal/hal_0.5.11.bb
+++ b/recipes/hal/hal_0.5.11.bb
@@ -1,6 +1,6 @@
require hal.inc
-PR = "r5"
+PR = "r6"
SRC_URI += " file://hal-right-input-h.patch;patch=1 \
file://fix-configure.diff;patch=1 \