summaryrefslogtreecommitdiffstats
path: root/recipes/handsfree
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/handsfree
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/handsfree')
-rw-r--r--recipes/handsfree/files/Makefile.patch19
-rw-r--r--recipes/handsfree/handsfree_0.1.bb32
2 files changed, 51 insertions, 0 deletions
diff --git a/recipes/handsfree/files/Makefile.patch b/recipes/handsfree/files/Makefile.patch
new file mode 100644
index 0000000000..6ca8dd2698
--- /dev/null
+++ b/recipes/handsfree/files/Makefile.patch
@@ -0,0 +1,19 @@
+--- handsfree/old/Makefile 2006-11-21 18:01:13.000000000 +0000
++++ handsfree/Makefile 2006-11-21 14:01:17.000000000 +0000
+@@ -9,12 +9,12 @@
+ # I use a dmixer as default alsa device to mix
+ # the handsfree output with other sound playback
+ #
+-ALSA_PLAY="default"
+-ALSA_REC="plughw:0,0"
++#ALSA_PLAY="default"
++#ALSA_REC="plughw:0,0"
+
+
+-LDFLAGS= -lbluetooth -lasound
+-CFLAGS=-g -Wall -DOSS=0
++#LDFLAGS= -lbluetooth -lasound
++#CFLAGS=-g -Wall -DOSS=0
+
+ all: handsfree headset
+
diff --git a/recipes/handsfree/handsfree_0.1.bb b/recipes/handsfree/handsfree_0.1.bb
new file mode 100644
index 0000000000..bd909a0140
--- /dev/null
+++ b/recipes/handsfree/handsfree_0.1.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "Handsfree and Handset Bluetooth tool"
+HOMEPAGE = "http://www.soft.uni-linz.ac.at/_wiki/tiki-index.php?page=ProjectBluezHandsfree"
+SECTION = "network/misc"
+PRIORITY = "optional"
+LICENSE = "GPLv2"
+DEPENDS= "bluez-libs alsa-lib"
+PR = "r0"
+
+
+SRC_URI = "\
+ http://www.soft.uni-linz.ac.at/~vogl/bluez/handsfree-040326.tar.gz \
+ file://Makefile.patch;patch=1 \
+"
+S = "${WORKDIR}/handsfree"
+
+# Alsa devices
+# Example: "plughw:0,0"
+ALSA_PLAY = "default"
+ALSA_REC = "default"
+
+CFLAGS =+ "-DOSS=0 "
+LDFLAGS =+ "-lbluetooth -lasound "
+
+do_compile() {
+ oe_runmake all
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 handsfree ${D}${bindir}
+ install -m 0755 headset ${D}${bindir}
+}