aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/hdparm
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <marcin@buglabs.net>2009-05-16 13:48:10 +0200
committerMarcin Juszkiewicz <marcin@buglabs.net>2009-05-16 21:16:12 +0200
commitce7d21308430468c4d0ef3b6e2642112be52bae9 (patch)
tree1ad27af9f418917fb819de81ca4f2e597a62711a /recipes/hdparm
parent32a26a50e11abddf6a4f3aaff8ad09a464211b3c (diff)
downloadopenembedded-ce7d21308430468c4d0ef3b6e2642112be52bae9.tar.gz
hdparm: added 9.15
Diffstat (limited to 'recipes/hdparm')
-rw-r--r--recipes/hdparm/hdparm_9.15.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes/hdparm/hdparm_9.15.bb b/recipes/hdparm/hdparm_9.15.bb
new file mode 100644
index 0000000000..d351e8dc85
--- /dev/null
+++ b/recipes/hdparm/hdparm_9.15.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "hdparm is a Linux shell utility for viewing \
+and manipulating various IDE drive and driver parameters."
+SECTION = "console/utils"
+PRIORITY = "optional"
+LICENSE = "BSD"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/hdparm/hdparm-${PV}.tar.gz "
+
+do_install () {
+ install -d ${D}/${base_sbindir} ${D}/${mandir}/man8
+ oe_runmake 'DESTDIR=${D}' 'sbindir=${base_sbindir}' install
+ mv ${D}${base_sbindir}/hdparm ${D}${base_sbindir}/hdparm.${PN}
+}
+
+pkg_postinst_${PN} () {
+ update-alternatives --install ${base_sbindir}/hdparm hdparm hdparm.${PN} 100
+}
+
+pkg_prerm_${PN} () {
+ update-alternatives --remove hdparm hdparm.${PN}
+}