aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/helloworld/helloworld_1.0.0.bb
diff options
context:
space:
mode:
authorLeon Woestenberg <leon@sidebranch.com>2009-11-26 21:25:43 +0100
committerLeon Woestenberg <leon@sidebranch.com>2009-11-26 21:25:43 +0100
commit4a021e985624d299dacbb66c17ffd6b70149476a (patch)
tree9a3bde4d6a12639acfd91e7eb5b31b8a9d58943b /recipes/helloworld/helloworld_1.0.0.bb
parentb37e2b2a2d9601f1bcc6094efc0d97755d6cfdc0 (diff)
downloadopenembedded-nios2.tar.gz
helloworld: Adhere to ${CFLAGS} and {LDFLAGS}. Ehrm...nios2
Signed-off-by: Leon Woestenberg <leon@sidebranch.com>
Diffstat (limited to 'recipes/helloworld/helloworld_1.0.0.bb')
-rw-r--r--recipes/helloworld/helloworld_1.0.0.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/recipes/helloworld/helloworld_1.0.0.bb b/recipes/helloworld/helloworld_1.0.0.bb
index af29a7769a..83b3965960 100644
--- a/recipes/helloworld/helloworld_1.0.0.bb
+++ b/recipes/helloworld/helloworld_1.0.0.bb
@@ -1,6 +1,6 @@
DESCRIPTION = "Minimal statically compiled Hello world!"
LICENSE = "GPL"
-PR = "r0"
+PR = "r1"
S = "${WORKDIR}/${P}"
@@ -11,7 +11,8 @@ do_fetch () {
}
do_compile () {
- ${CC} -o helloworld helloworld.c -static
+ ${CC} ${CFLAGS} -c -o helloworld.o helloworld.c
+ ${CC} ${LDFLAGS} -o helloworld helloworld.o -static
}
do_install () {