aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/help2man
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2010-11-17 17:45:19 -0700
committerTom Rini <tom_rini@mentor.com>2010-11-18 07:29:23 -0700
commite01784b74841d142a1cfbc61a6af86e8069bd0ed (patch)
tree5c5c75ebd9746d63cdbacc85882b361f08cc3821 /recipes/help2man
parente06468eb138fc5e354878b41e395bec238fed872 (diff)
downloadopenembedded-e01784b74841d142a1cfbc61a6af86e8069bd0ed.tar.gz
help2man: Add native recipe, drop check for being provided.
With a recent change to auto* to not build the man pages for native recipes, we can make build progress without help2man being there already. This adds help2man to local.conf.sample as an example of something that is assumed to be provided, drops the sanity.bbclass check and adds a help2man-native recipe. In order to catch the cases where help2man is likely to have been an implicit requirement before we add it to the list that autotools brings in. Signed-off-by: Tom Rini <tom_rini@mentor.com> Acked-by: Michael Smith <msmith@cbnco.com>
Diffstat (limited to 'recipes/help2man')
-rw-r--r--recipes/help2man/help2man_1.37.1.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/help2man/help2man_1.37.1.bb b/recipes/help2man/help2man_1.37.1.bb
new file mode 100644
index 0000000000..769f86b099
--- /dev/null
+++ b/recipes/help2man/help2man_1.37.1.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "Program to create simple man pages"
+SECTION = "devel"
+LICENSE = "GPLv3"
+DEPENDS = "gettext-native perl-native liblocale-gettext-perl-native"
+DEPENDS_virtclass-native = "perl-native-runtime"
+RDEPENDS_pn-help2man = "gettext perl liblocale-gettext-perl"
+PR = "r0"
+
+SRC_URI = "${GNU_MIRROR}/help4man/help2man-${PV}.tar.gz"
+SRC_URI[md5sum] = "371b5cc74fe9c2ea3ee1ca23c19b19a8"
+SRC_URI[sha256sum] = "3b44a91ef8e722c570a2a2d0e3f1cd249aac25dd2b2692c7792d87b30ed61561"
+
+inherit autotools
+
+EXTRA_OECONF = "--disable-nls"
+
+BBCLASSEXTEND = "native"
+
+# We don't want to reconfigure things as we're using host perl
+do_configure() {
+ oe_runconf
+}