aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/horizon/horizon_cvs.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/horizon/horizon_cvs.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/horizon/horizon_cvs.bb')
-rw-r--r--recipes/horizon/horizon_cvs.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes/horizon/horizon_cvs.bb b/recipes/horizon/horizon_cvs.bb
new file mode 100644
index 0000000000..bfa26b54a1
--- /dev/null
+++ b/recipes/horizon/horizon_cvs.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "Horizon is a sketchbook application for tablet devices."
+LICENSE = "GPLv2"
+SECTION = "x11/graphics"
+DEPENDS = "glib-2.0 libpng jpeg virtual/libsdl"
+PR = "r1"
+
+SRC_URI = "cvs://anonymous@anoncvs.gnome.org/cvs/gnome;module=horizon \
+ file://makefile.patch;patch=1"
+
+inherit pkgconfig binconfig
+
+S = "${WORKDIR}/horizon"
+PV = "0.37+cvs${SRCDATE}"
+
+PARALLEL_MAKE = ""
+
+CFLAGS += " -I${STAGING_INCDIR} -I${STAGING_INCDIR}/SDL -I. -Isrc -L${STAGING_LIBDIR} `PKG_CONFIG_PATH=${STAGING_DATADIR}/pkgconfig pkg-config --cflags glib-2.0 gobject-2.0 libpng`"
+
+do_compile() {
+ #yes, this is a hack to work around a faulty makefile
+ oe_runmake horizon
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 755 horizon ${D}${bindir}
+}
+