aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/hostap
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-06-02 15:04:25 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-06-03 07:33:27 +0200
commitd4276bed389b7db06db58c7acebb83f92bff86a5 (patch)
tree2386574b6ab0c36a58a314a24d31f6b5c9291a65 /recipes/hostap
parent823aa270059259ca619e21a5d9b22e86afb12f3b (diff)
downloadopenembedded-d4276bed389b7db06db58c7acebb83f92bff86a5.tar.gz
recipes: conform to OE packaging guidelines with RDEPENDS/RRECOMMENDS
* there is probably very few cases when it's needed without _${PN}, if you find one in attached patch, please enlighten me * usually we want those only for ${PN} not for all ${PACKAGES} ie ${PN}-dev, ${PN)-doc etc * there is a check for this in recipe-sanity.bclass * there is maybe few possible fixes also in bbclasses cpan-base.bbclass:RDEPENDS += "${@["perl", ""][(bb.data.inherits_class('native', d))]}" distutils-base.bbclass:RDEPENDS += "python-core" gtk-icon-cache.bbclass:RDEPENDS += "hicolor-icon-theme" image.bbclass:RDEPENDS += "${IMAGE_INSTALL} ${IMAGE_BOOT}" module.bbclass:RDEPENDS += "kernel (${KERNEL_VERSION}) update-modules" ?opie_i18n.bbclass: rdepends = bb.data.getVar("RDEPENDS", d, 1) ?opie_i18n.bbclass: bb.data.setVar('RDEPENDS_%s' % x[0].lower(), pn, d) ?opie_i18n.bbclass: bb.data.setVar('RDEPENDS', rdepends, d) rubyextension.bbclass:RDEPENDS += "ruby" Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Koen Kooi <k-kooi@ti.com>
Diffstat (limited to 'recipes/hostap')
-rw-r--r--recipes/hostap/hostap-conf_1.0.bb2
-rw-r--r--recipes/hostap/hostap-daemon.inc2
-rw-r--r--recipes/hostap/hostap-modules.inc2
3 files changed, 3 insertions, 3 deletions
diff --git a/recipes/hostap/hostap-conf_1.0.bb b/recipes/hostap/hostap-conf_1.0.bb
index e0909dde3f..70ff05dcef 100644
--- a/recipes/hostap/hostap-conf_1.0.bb
+++ b/recipes/hostap/hostap-conf_1.0.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "PCMCIA-cs configuration files for wireless LAN cards based on Int
SECTION = "kernel/modules"
PRIORITY = "optional"
LICENSE = "GPL"
-RDEPENDS = "update-modules"
+RDEPENDS_${PN} = "update-modules"
PACKAGE_ARCH = "all"
PR = "r9"
diff --git a/recipes/hostap/hostap-daemon.inc b/recipes/hostap/hostap-daemon.inc
index 33dc1c140e..fe7456027c 100644
--- a/recipes/hostap/hostap-daemon.inc
+++ b/recipes/hostap/hostap-daemon.inc
@@ -3,7 +3,7 @@ HOMEPAGE = "http://hostap.epitest.fi"
SECTION = "kernel/userland"
PRIORITY = "optional"
LICENSE = "GPL"
-RDEPENDS = "hostap-utils (${PV})"
+RDEPENDS_${PN} = "hostap-utils (${PV})"
DEPENDS = "openssl"
DEPENDS_append_mtx-1 = " madwifi-modules"
DEPENDS_append_mtx-2 = " madwifi-modules"
diff --git a/recipes/hostap/hostap-modules.inc b/recipes/hostap/hostap-modules.inc
index 40e6742c45..02d880cf89 100644
--- a/recipes/hostap/hostap-modules.inc
+++ b/recipes/hostap/hostap-modules.inc
@@ -2,7 +2,7 @@ DESCRIPTION = "A driver for wireless LAN cards based on Intersil's Prism2/2.5/3
SECTION = "kernel/modules"
PRIORITY = "optional"
LICENSE = "GPL"
-RRECOMMENDS = "apm-wifi-suspendfix"
+RRECOMMENDS_${PN} = "apm-wifi-suspendfix"
SRC_URI = "http://hostap.epitest.fi/releases/hostap-driver-${PV}.tar.gz"
SRC_URI_append_mtx-1 = " file://mtx_compat.diff;striplevel=0 \