aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/hotplug-ng/hotplug-ng_001.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/hotplug-ng/hotplug-ng_001.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/hotplug-ng/hotplug-ng_001.bb')
-rw-r--r--recipes/hotplug-ng/hotplug-ng_001.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes/hotplug-ng/hotplug-ng_001.bb b/recipes/hotplug-ng/hotplug-ng_001.bb
new file mode 100644
index 0000000000..c76c0f06eb
--- /dev/null
+++ b/recipes/hotplug-ng/hotplug-ng_001.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "This collection of code replaces the existing linux-hotplug \
+package with very tiny, compiled executable programs, instead of the \
+existing bash scripts."
+LICENSE = "GPL"
+RPROVIDES = "hotplug"
+RCONFLICTS = "hotplug"
+RREPLACES = "hotplug"
+PR = "r1"
+
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/utils/kernel/hotplug/hotplug-ng-${PV}.tar.gz \
+ file://flags.patch;patch=1"
+S = "${WORKDIR}/hotplug-ng-${PV}"
+
+LD = "${CC}"
+export HOSTCC = "${BUILD_CC}"
+# Stripping should be done when _packaging_, not building
+EXTRA_OEMAKE += "'STRIP=/bin/true'"
+
+export etcdir = "${sysconfdir}"
+export sbindir = "${base_sbindir}"
+export bindir = "${base_bindir}"
+
+do_install () {
+ oe_runmake 'DESTDIR=${D}' install
+}